After updating to copter 4.0 drone crashes

Hi, I have updated the software in my cube black to copter 4.0 and it now crashes after take off.
I have re-calibrated all parameters.

What can possibly be wrong?

This is the bin file:
2020-07-06 20-45-46.bin (961.0 KB)

700mm frame
15" carbon props
Motors T-motor MN4006-23 KV380
ESC T-motor Air 40A
6s Battery

It has been flying for several years without any trouble. After software update it crashes almost right after take off.
I hope someone can help me.

Kind regards,

Looks like it was OK in the log. You took off in stabilize and cut the throttle to zero and it tipped over?

Maybe you can describe what happened in more detail?

I took of in loiter, hovered at 2m from the ground, did not move the throttle and it tipped over.
I tried this 5 times, every time the same issue.

The log shows you in stabilize and cutting the throttle.

Maybe you uploaded the wrong one?

I could be mistaking that it was in stabilise (I tried both) but I certainly did not cut the throttle. Is this not the safety system cutting the throttle after the crash?

No, that it the RCIN log message.

Throttle goes down then roll and pitch go off.

If you thought you were in loiter cutting the throttle would be to descend. But you we actually in stabilize so cutting the throttle is a crash.

I looked at the log with MODE checked. The FC was in Stabilize when throttle was cut.

I am a noob in this area.
But I am very sure I did not cut the throttle myself, how can this happen? loss of signal?

No. If you had this FC setup properly loss of signal would trigger an RTL or a in this case a landing, not a crash.

and all the other channels look solid…

You are right. RTL was programmed and used in the past.

Instead of looking at RCIN, open the CTUN branch and tick ThI (Throttle In), ThO (Throttle Out) and ThH (Throttle Hover).

This aircraft is massively over powered to the point were there is very little stick resolution between full low and hover.

BTW, I have that frame too…

Check your frame type.
It shoes as Octa_Quad in the log file

Edit : ITYS

What was the firmware version that you updated from ?

I think you are right! The logo in mission planner is not so clear. I connected to Q ground control and could see the Oxtaquad selection, I will change it and try to launch.

I have updated from 3.5.0.
No other changes were made.

I do not think it is massively overpowered. I use an 8000mAh battery and a gimbal with a Sony RX-100 (not mounted while testing).

I have calibrated the radio for smooth throttle reaction, this is even on the low side in order not to ascend too fast.
It has been flying for years without problems.

This is the CTUN data, I do not understand what this means, can you see anything wrong?

CTUN (Control, Throttle and altitude information):

TimeUS Time stamp for messages in microseconds (can be ignored)
ThI The pilot’s throttle in as a number from 0 to 1000
ABst Angle Boost: throttle increase (from 0 ~ 1000) as a result of the copter leaning over (automatically added to all pilot and autopilot throttle to reduce altitude loss while leaning)
ThO Final throttle output sent to the motors (from 0 ~ 1000). Normally equal to ThrI+ABst while in stabilize mode.
ThH Estimated throttle required to hover throttle in the range 0 ~ 1
DAlt The Desired Altitude while in AltHold, Loiter, RTL or Auto flight modes. It is influenced by EKF origin, which in 3.5.X is corrected by GPS altitude. This is behaviour is turned off in 3.6.X and can be turned on with EKF_OGN_HGT_MASK.
Alt The current EKF Altitude
BAlt Barometer Altitude: The altitude above ground according to the barometer
DSAlt Desired distance in cm from ground or ceiling (only visible if Sonar is available)
SAlt Sonar Altitude: the altitude above ground according to the sonar (Only visible of Sonar is available)
TAlt Terrain altitude (not used by default)
DCRt Desired Climb Rate in cm/s
CRt Climb Rate in cm/s
N Harmonic notch current center frequency for gyro in Hz

The problem is solved!
It was the wrong quad selection (octaquad instead of quad). Bit of a dumb mistake :frowning_face:

Thank you all for your assistance!