After building custom firmware, error message: "prearm motors check frame class and type"

Been trying to build a custom firmware for a Kakute F7 that includes OSD capability for HDZero.

After installing the custom firmware, the OSD does indeed work (great!!). But…I get an error message on bootup - “prearm motors check frame class and type”. Plus, I see EIGHT motor test tabs (should be four), and motor testing does not work, and, the drop-down box for ESC type is blank.

I repeatedly went to the Mission Planner page to set the frame type (which was already set correctly, Quad, X), but nothing I change makes the error message go away.

If I revert to the latest stable release, the frame class and number of motors and motor test all go back to normal and work fine, but then of course the OSD does not work.

Any idea what’s going on?

Thanks…

Do you go into full parameter tree and set the frame and class then reboot?

Thanks yes, I checked, and it was already set to Quad X. The GUI and params are both set correctly.

@wsalopek,

If you could provide an onboard log we might be able to see what the issue is. It will probably be necessary to set LOG_DISARMED = 1 so that a log is produced even though the vehicle is not armed.

Randy the next custom firmware I built (which was the third or fourth in a few days time) no longer has the frame class error. If it pops back up, I’ll post.

Thanks…

1 Like

I’m having this issue too. Seems to happen when I select OctoX frame, if I were to select QuadX then there is no issue. I’ll add the bin file. I’m building custom as I have a Pixhawk 1M and need gripper.

2022-11-26 11-01-53.bin (736 KB)

Make sure to add the frame type to the build, by default you only get quads to make room for other stuff.