Advice please,ArduPlane Failsafe+RFD radio

When I switch off my Horus radio with RFD radio on my plane the airelon’s go into a full left hand turn,e/g left aileron full up and right full down I dont think this is correct I no it should go into cicle as part of failsafe but not soue about what it is doing now,many thank’s in advance

If you did not set any failsafe position on your receiver, Arduplane will enter the “No RC receiver” state. You should connect your flight controller to Mission Planner and see the exact message on the HUD. After you turn off your radio, it should enter “CIRCLE” mode for a few seconds and after that it will execute RTL.

1 Like

Have the plane connected to Mission Planner when you turn off the radio and see what mode it’s going into. It may be going into full deflection because it’s going into circle or RTL but because it’s likely sitting on it’s home point it thinks it needs to make a sharp turn to start the maneuver. Sometimes when you’re testing on the bench (or garden) it’s hard to say exactly what it’s going to do in flight.

Confirm the modes in MP first.

1 Like

Thank you Florin and Allister,will go check that and report back Ardupilot rules the Air Waves

Hi gents,fail safe is not working,it aint going into circle or rtl,I tried your work around Allister with out any luck back to drawing board for me

It is hard to say what is happening judging only by what the plane seems to do or not. You must connect the USB port to a computer and confirm the flight modes.

1 Like

yes ive done that Florin and it is staying in what ever mode im in when I switch radio off

You have to use MissionPlanner sik radio section or RFD Tools, get the radios all connected and up and working.
Set your transmitter EXACTLY how you want the aircraft to behave in failsafe - throttle position, flight mode, flight controls, all switches and settings - then press the Set PPM Failsafe button for the air unit.
This will work best if one of your switches is configured for RTL or Land, whatever you deem necessary.


thank you Shawn will give that a go now

Hello my friends,ive spent hrs trying to configure the fail safe n the rfd just doing something wrong,will spend some more time as pouring of rain here,fail safe is last part of jigsaw so need to perservere

Depending on the receiver you are using (I really don’t know anything about Horus), you connected it to the flight controller board by PPM or SBUS, right? (could be PWM but I hardly doubt it :slight_smile: ). PPM and SBUS are a little different when setting failsafe with Ardupilot. With PPM you just set the receiver failsafe as described by @xfacta but with SBUS you need to change one Arduplane parameter too: RC_OPTIONS parameter must be set to 2 - “Ignore Receiver Failsafe bit but allow other RC failsafes if setup”.

1 Like

Thank you Florin,im using the pass through on the RFD to do the radio stuff,every thing else works awesome,will try again with trims

At the moment Florin and Allister,I have got it kinda working,when I tried with the extended trims it would not work.So I set RTL up as flight mode then did fail safe on RFD gui,Now when I switch off the radio it goes into RTL so that is working,should i set throttle at say 55/60% to be sure I have power,sorry for questions but just about there I think

1 Like

Arduplane can do throttle management by itself, you don’t have to store a high THR stick position during the failsafe. Back in time, when you were flying your plane, did you use the THR stick during RTL mode (initiated from your radio’s switches)? You can add some manual throttle during RTL but for most cases (on default settings) Arduplane will run the motor during the way home. You won’t see the motor running on the benchwork because of a few safety default features. Nevertheless, if you have GPS lock and give the plane a mission in AUTO mode, it will start the motor, so take care of your fingers :slight_smile:

1 Like

Thank you,yea was maybe over thinking the throttle,but im happy now at least it goes into RTL so some safety there will try again with the low trims at some point

1 Like