Advanced PID writing permission


when connecting the laptop to my octocopter (coaxial quadcopter design with Pixhawk) I am not able to rise the Advanced PID Tuning Parameters within the MissionPlanner GUI Interface more than the preset maximum. However, I can lower them with the indication arrows aside the description fields. Is there a possibility to write Parameters higher than the default setting (e.g. P>0.5)? Do I have to change some parameter defaults to do so?

My workaround for the moment looks like that:

  • connecting via wifi or USB-cable (connection is established without error messages, parameters are loaded regularly)
  • Setting CH6 to the desired Parameter
  • Setting CH6 parameter to the desired value (Max=Min)

By doing so, the value is changed the way I need it. However, changing CH6 to another value reference (e.g. from PitchP to PitchD) results in loosing the parameter I set before, although i had saved the settings with the “saving”-button. The only solution for now is to physically start the octocopter after each changing of a single parameter by rising the throttle. By doing so, the parameter is saved into the Pixhawk and can be read out by hitting the “refresh”-button within the advanced PID tuning tab.

How can I input all the Advanced Parameters at once and push them into the Pixhawk?
In a perfect world I want to change all settings once in the MissionPlanner-GUI and then save them to the Pixhawk…

Is there a known Read/Write Permission Issue between MissionPlanner and Pixhawk?

I have the latest MissionPlanner version installed (1.3.44 build 1.1.6240.11550).

Thanks for your advice!