Acro goes out of control on flip

I have just started using rtfhawk/arducopter on quads. Tried acro, works. Im using mode1, which does autolevel, but does not limit angle.

A couple of times now, I try a flip (which works normally often), and it will keep flipping even after control is released. this is done very high, and I switch to stab. It does not stab, it keeps flipping.

Crashed 2x.

I looked at telemetry; the rc pitch input goes to 0 as it should. something like despit variable seems to hang around for a sec or 2, seeming to give a pitch command I am not asking for.

But also, stab will not bring it out of this. the 2nd crash, I fought it, and that seemed to help…there was no damage. but it came down hard…it did not seem to have stab, or was continuing to go were I did not command.

I have telemetry.

Any ideas?

Anyone else have this happen?



BTW, this is disappointing. I was enjoying acro, and wanted to try it on my other aircraft. would like to get this resolved.

I wonder if noone else has reported this, if it might be because I am using the mode 1 option, which will autolevel when stick released. Something seems to be extending despit beyond my rc command, but only on maybe 20% of my flips. It may be when I pull full back, possibly saturating…just a guess.

How about providing tlogs and/or data flash logs to help troubleshoot your issue?

This is an issue which could not be solved during Beta testing, you need to disable Acro trainer to solve.
Hope the dev team will find a solution for this.

Thanks for your interest/help, and sorry for the delay. I just checked back in and found you reply.

I will try to get the logs posted tomorrow.

thanks again.

wanted to go ahead and get out the mission planner log.

there are 2 flips. the 1st one works. the 2nd one is the crash, which shows at about 91% of the log duration.

I tried to fight this one with stick input, when it was continuing to flip after switching to stab with the sticks at neutral. It seemed to slow the decent, and I have no damage, thought I hit hard/sideways on soft turf.

I can send the flash tomorrow, and I also have the first crash I can send if you need it. Please let me know.

thanks again.

I tried to upload the flash log, it is too large.

Is there a way for me to get that to you?

thanks, Jim

anyone else tried this mode with any results?

It is now May, and still no response. I am unable to try flips in acro for fear of crashing again…very discouraging for use of this product.

I use acro without issue. Can’t help without a log. Some people use Dropbox if too big. Or if trying to post the .log file, post the .bin file instead.

sent from my phone so apologies for any typos

So i just attempted a flip in acro. I started out by giving it full throttle vertical for a little moment to give it some momentum, then full left for maximum roll while lowering throttle to about 50%, but the copter stopped after about 100 degrees of rotation in the roll axis and came down really fast. Did not appear to responed properly to commands. As a last resort i changed to rtl pretty close to the ground and the copter barely leveled out and slowed down somewhat. was a pretty hard landing but no significant damage.

This made no sense to me. Surely acro is ment to be able to roll 360% degrees? now to examine settings to see if theres something i’ve missed… Copter 3.2.1

A little update to my last post. After going through the settings, i found acro trainer to be set to 2, autolevel and angle limit. But this still doesnt explain why the copter stopped at around 100 degrees, as the limit was set at 45 degrees. I’m thinking this might be worth looking into for the developers. As for the copter not responding properly after stopping at 100 degrees, this could be a simple brain freeze :mrgreen: but i cannot be sure, and i dare not try it again :open_mouth: This is a quad im talking about btw.

Anyway, i disabled angle limit, and increased acro rates to 400deg/s. Also upped expo a littlebit. Now it works well. Effortless flips.