Accidentally pressed “remove missing”

I mistakenly and blindly pressed the remove missing button and now when I try to boot up mavproxy on my pixhawk + RBPi build I get a compass 2 not found error, is there anyway to fix this? Should i try reflashing the pixhawk?

Do you have any older parameter list? You can try to read it again and re-set your parameters.

i am suffering from the same problem. but i dont have previous perameters saved.

i attached external compass. nut i cant see i compass section. i accidently pressed “remove missing” button. plese help me…

Reboot, reconnect and re-calibrate the compass

I’ve already tried…!!

Then the compass is really missing and you can not calibrate a non-existing compass.

Check the cables, all expected compasses must appear.

Otherwise you are trying to solve a problem that does not exist.

Wires are connected…!!

wired correctly ? SDA with SDA and SCL with SCL. The GPS works ? (HUD display must not be “NO GPS”, “NO FIX” would be OK. I assume that the compass is located in the GPS housing)


Did you try reflashing it? I believe that thats what I did and it reappeared.

The HUD display is also not working… And may be all wires are correct…still problem not solved.

I think my gps Stop working after I press “remove missing”.

“missing” only happens if you happen to plug a compass and after you unpluged it. So if you just plug a new one or the old one you had it will reappear in the list as active. If you are so sure, that this option caused you any trubles, then:

  1. Save your params
  2. Write a new firmware other than your desired one to wipe everything clean
  3. Write your desired firmware
  4. Compare your old params via mission planner and write ONLY your tuning params, battery etc.

Now you have all your old tuned airframe and ready to freshly tune your Gyros Compass etc that are detected.

1 Like