Servers by jDrones

Access to COM port is denied; trouble loading firmware

I am experiencing difficulty loading firmware onto my Pixhawk. I have tried loading firmware with both AMP 2.0 and Mission Planner.

In Mission Planner, when trying to establish a connection on COM4 on port 9600, I receive this error:

All peripherals are uplugged (note: when I had the peripherals plugged into the Pixhawk, all i got was the “no response from board” error. Unplugging the peripherals seems to have improved the situation somewhat). Have tried with both LiPo battery plugged in and unplugged.

Driver appears to be functioning correctly:


check you don’t have some other software on your pc this is using the comport.

Delete all of programs, such as Mission Planner. It helped me!! :mrgreen:

@sysanin
What do you mean? Delete all of programs? What?

Remove drivers and reinstall them.
Start Mission Planner, press CTRL-F and select driver clean.
After that install this package https://firmware.ardupilot.org/Tools/MissionPlanner/driver.msi which contains latest drivers.
Don’t forget to reboot

Did everything, no help.

My problem is Navio connecting to Mission Planner giving the error of “Access denied”, and in QGround “Could not create port. Access is denied” error is given.

Acces denied means that something else is using that port. Try this to figure out which process is using it. https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P8CLSA0

Servers by jDrones