Accels inconsistent

Hi all,

After making an Autotune and then landing, the lights of Pixhawk cube change to yellow and Mission planner says “accels inconsistent”. I recalibrated accels several times and failed. Days afterwards I tried again and was successed.I did another flight making another autotune and happened the same thing. Now I recalibrated accels many times with no succes. I cant send the log bacause it says is too big. thanks in advance.

You need to attache a link to the log file you have placed in cloud storage somewhere (Dropbox, etc)

Thanks Dave,

here it is.



I managed to to calibrate access again, and did two proper flights and then at the third again access inconsistent. Can anybody help me please thanks.

did you leave the cube to warm up before calibrating? it takes 20 mins or so to get up to temp.

Post another log that is not AutoTune.

Hi Peter, here is the new log. Just after landing said the message “accels inconsistent”

Peter, Thanks for the suggestion. I,ve been using ardupilot for 3 years. Never waited such a long time and never had this problem. I tried anyway.

I see you have INS_USE (1,2&3) enabled but EK2_IMU_MASK is set to 3 (1st and 2nd only). Perhaps this needs to be set to 7 for all 3? I don’t have a Cube Black but there was all kinds of scrum about this some months ago.

I’ll check this.
Do you believe me if I tell you that I have downgraded to AC 3.9 and now everything is fine with accels?
I’ve flown just once and everything is fine. I’ll try tomorrow another flight to confirm.