Accelerometer Calibration Fail

After a successful flight yesterday with my Black Cube controlled Hex it wouldn’t arm today and gave an ‘Accels inconsistent:’ error. I tried recalibrating the accelerometers but after placing the machine on its back it failed the calibration. I tried this a number of times, but it always failed. Calibration Level worked OK.

Are there any parameters I can relax that would help or is it possibly a hardware issue?

Any help would be appreciated!

Are you using MP or Q ground Control?

I’m using Mission Planner.

Hmm… You can try reloading the firmware. I am assuming you have the latest firmware.

Could be bad IMU.

Check this thread https://discuss.cubepilot.org/t/inconsistent-accel/2179

Hi
Thanks for the link which was very helpful and it seems I also have an IMU3 failure.
When it arms I also have been flying it on a mapping mission and it keep aggressively hunting to keep on the vertical path and I assume the faulty IMU would be the problem?
I attach a log which shows the erratic altitude keeping. The flight path is up and down the side of a hill but the altitude line should be a lot smoother?
Is it OK to disable an IMU and still fly safely?
Thanks
Peter


I personally don’t know if disabling the IMU is a risky proposition or not. I guess as long as it’s not used.

I am copying Eosbandi and dkemxr they can give you a better answer.

The clone FC are nasty. get a brand one this time.

Hi Asim
Thanks again. It is genuine Black Cube.
Peter

The Cube has 3 sets of IMU sensors for extra redundancy. If I make an educated guess, it should be ok to turn off IMU 3.

@proficnc may be someone can help this guy?

Send an email to proficnc…if its defective they will give you a new one.

1 Like