Servers by jDrones

Ac3.5 rc roll not configured

pixhawk2
arducopter

(CAO MUQING) #1

Problem summary: MP shows 'prearm: RC ROLL not configured’
Hardware: Pixhawk2.1
Problem description: One of my Pixhawk2.1 is having a strange issue. When i load arducopter3.4, it is able to arm completely fine. However, when I load beta AC3.5 rc11, the mission planner HUD shows ‘prearm: RC ROLL not configured’ whenever I try to arm. I have tried to calibrate RC a few times but it still shows the error.

Really appreciate anyone to help with this issue.


Dev Call Apr 16, 2018 2300 UTC
(Dave) #2

It will show that error if it sees the default values for RC1 PWM because it thinks the radio is not calibrated.


(CAO MUQING) #3

Thanks for your information! If that is the case, how should I address it, changing the RC1 PWM parameter? Since I have tried calibrating RC for a few times…


(rmackay9) #4

CAO,

In some rare cases it’s possible that a transmitter produces exactly 1100 as the minimum and 1900 as the maximum in which case the regular rc calibration will not make the warning go away. One work around is to manually change the RC1_MIN to 1101 and RC1_MAX to 1901. You should only do this though if you see that the RC1_MIN is 1100 and RC1_MAX is exactly 1900. If it’s not then there is a different problem.

Another possible cause, for example, is the min, max or trim values are far away from the expected values. It’s impossible to be sure about this though without seeing a dataflash.


(CAO MUQING) #5

randy,

thanks for the reply! I will try to change the value.
Strange thing is that on 3.4 there is no error, but 3.5 will show the error.


(peterbarker) #6

In some rare cases it’s possible that a transmitter produces exactly 1100 as
the minimum and 1900 as the maximum in which case the regular rc calibration
will not make the warning go away. One work around is to manually change the

Ah, actually, my reading is that we don’t use these values to determine
whether your (e.g.) ROLL is configured.

Here’e the call we make to see if the channel is configured:

https://github.com/ardupilot/ardupilot/blob/master/ArduCopter/AP_Arming.cpp#L352

Here’s the definition of that call:

https://github.com/ardupilot/ardupilot/blob/master/libraries/RC_Channel/RC_Channel.h#L102

And here are the AP_Param objects that’s calling methods on:

https://github.com/ardupilot/ardupilot/blob/master/libraries/RC_Channel/RC_Channel.h#L113

“configured” on an AP_Int16:

https://github.com/ardupilot/ardupilot/blob/master/libraries/AP_Param/AP_Param.h#L389

And I’m sure we really don’t want to go digging deeper into AP_Param, for
there be dragons. Suffice to say that AP_Param doesn’t know anything
about magic PWM values :slight_smile:

RC1_MIN to 1101 and RC1_MAX to 1901. You should only do this though if you
see that the RC1_MIN is 1100 and RC1_MAX is exactly 1900. If it’s not then
there is a different problem.

So when you explicity set those to a value that’s different to the default
value it will result in a write to storage, meaning “configured” will
return true, fixing the problem.

However - why is MP not getting that same effect from its calibration
screen? Perhaps it isn’t sending through a param-set if the value hasn’t
changed?


(peterbarker) #7

Ah, actually, my reading is that we don’t use these values to determine
whether your (e.g.) ROLL is configured.

It does occur to me that perhaps the “force save” parameter might not be
being set, however.

https://github.com/ardupilot/ardupilot/blob/defered-message-fix/libraries/GCS_MAVLink/GCS_Param.cpp#L267


(mingf) #8

I am having the exactly same problem. Pixhawk 2.1, with AC3.4, there was NO problem. loaded AC3.5, “Prearm: RC Roll not confgiured”.

after I calibrate RC, this error mesg went away. HOWEVER, when I fly my copter ( quad ), the roll does not work correctly. it led to crashes, I tested several times.

also, I upgraded mission planner to 1.3.49, it is not able to load AC3.5 onto my pixhawk 2.1

I had to use qgroundcontrol to load ac3.5, set the frame using qgroundcontrol. Otherwise, mission planner 1.3.49 keeps saying: prearm: check platform or frame_class.

so I would have to say: AC3.5 is a failure, stay with 3.4, do NOT go 3.5. hopefully these fatal bugs can be fixed as quickly as possible.

my same pixhawk 2.1, NO issue with AC3.4. Sadly becomes a piece of junk with AC3.5, 100% useless now.


(mingf) #9

with AC3.5, when I use roll function, the quadcopter got messed up, crashed, I tested multiple times. with AC3.4, no issue, flying very smooth. so AC3.5 roll portion must have serious fatal flaws which, I hope, can be fixed quickly.


(mingf) #10

another funny weird thing of AC3.5: you have to turn on RC first, otherwise, it keeps saying: prearm: throttle below failsafe value… AC3.4, it doesn’t matter, no issue if you turn on RC after connecting mission planner…

So AC3.5 is seriously wrong, no go! or wasting a lot time, multiple crashes, regret.


(mingf) #11

Re-verified by fall-back to 3.4.6, so thos 3.5 issues are gone. So the 3.5 PROBLEMS I run into are ( mine is Pixhawk 2.1, the cube ):

  1. RC roll issue. “Prearm: RC Roll not configured”. even after I calibrate RC, this mesg went away, the roll actually doesn’t work correctly. The roll crashed my quadcopter several times once I used the “roll” stick. with using the roll stick, the copter still flys OK.
    so 3.5’s roll crashed my copter several times, broke two props.

  2. it can NOT determine the frame type, mine is quad/X, 3.4 tells it NO issue at all. For 3.5, I have to manually set it.

  3. Prearm: throttle below failsafe.
    I have to turn on RC before connecting mission planner to avoid this error mesg. On 3.4, I do NOT have to do this. I can turn on RC at any time, before or after connecting mission planner.

RC roll problem is fatal, is the killer. I can NOT go 3.5. it crashes my cube pixhawk 2.1. again, fall back to 3.4, everything is back to normal good.

I am hoping these issues can be fixed as quickly as possible.


(Didzis Kristaps Stūris) #13

Where can get AC 3.4 to download. I got the same problem. I have Solo with Green Cube on rc3 upgraded from rc1. Got fly 2 times and today the same error. After factory settings reset do to problem with Wi-Fi.


(brandon macdougall) #14

I not tested it on my Cube but 3.5 works well on my Pixhawlk. I think its a good idea to reset your setting to Default and recalibrate all when things go south sometimes could be as simple as bad wright to the sim card.