Servers by jDrones

AC 3.6.3 - Drone crash during normal flight (Loiter) - why? (inc. LOG)


(Ingo Pirker ) #1

Hello, i had a few flights today - only some Missions and some Loiter actions. Everything works fine, but at the last flight my Copter went out of control.

Some technical stuff:
Copter in X8 configuration (MTOW 25kg - at this flight about 16kg)
Pixhawk 2.1 with AC3.6.3
two Ublox NEO M8N + LIS3MDL from CSG Shop (https://www.csgshop.com/product.php?id_product=256)
two aditional LIS3MDL (so that i have 3 external mounted Compasses)
Mauch Power-Cube 4 “V3”
Mauch PL-200 200A Current Sensor
12S LiIon Batterys
RFD868X for RC control and Telemetry

The log file shows, that from flight minute 16:07 the Motor PWM signals are limited between 1200 and 1500us. Any idea why?

In panic i flipped the Motor Interlock (CH12) switch at Flight Minute 16:07:35. I tried to flip it back the Switch, to recover off the freefall, but the copter was already to near at the ground - Impact :-(.

Link to LOG File: https://www.dropbox.com/s/lzpgpvbfgxhbm3s/00000020.BIN?dl=0

So please - can someone of you guys help me with the analysing?
Thanks a lot!


(Mike Boland) #2

Looking at the logs I can see no real event that might have triggered the crash except that you were pushing it around hard with the Tx sticks.
So I checked your ATC_RAT_RLL_FILT and ATC_RAT_PIT_FILT and they were at the defaults of 20.
Have a read here about bigger copters.
I assume you had not done an autotune yet?

Had a similar thing happen to a large Octo once where I forgot to set those parameters.
Was flying OK while I pushed it around until it suddenly flipped out of the sky.


(Ingo Pirker ) #3

Hello Mike.
Thanks alot for your help!

Yes i tried to push the copter with the sticks a little bit, so that i can be shure that the copter will fly - also in hard conditions.

You are right, i didn’t make any tuning, because the copter flies very well with the default parameter.

So for the next flight you mean:
#1 Set the ATC Parameter to a smaler number (10Hz)
#2 make a AutoTuning
#3 try again to fly
basically follow the instruction in the link.

I am a little bit afraid to test it another time, without knowing what caused the real issue - or is it to 100% the wrong settings of the ATC Parameter.

I am using Arducopter for professional Systems since the beginning - started with the first APM - never head real problems, but this give me headaches.

Thanks a lot and i hope the community can help me to be shure.