AC 3.5-rc9 need help with possible ESC calibration problem

I have a 250 size quad with a Pixracer and BusyBee2 4in1 20A ESC board. The ESC protocol is set to Normal.

I was running 3.4.6 on this quad and it worked well, hovering around mid throttle. Last week I upgraded to 3.5 rc8, recalibrated RC and ESCs with Mission Planner (latest beta), and it still worked well, hovering around mid throttle. Today I upgraded to 3.5 rc9, recalibrated RC and ESCs, and now it hovers around 25% throttle stick.

My TX is a Taranis 9D+ with OpenTX 2.2. I have no throttle curves set on the TX or in AC. When I set the throttle stick to the mid point Mission Planner says 1500.

I’ve attached a log from a short test flight, and my reading of this is RCIN C3 (throttle) shows it was hovering with RC of about 1250, which is consistent with the observed 25% throttle stick to hover.

I could use some help identifying what caused the hover point to change from 50% stick to 25% stick, and how I might fix this. I’ve recalibrated the ESCs in rc9 several times and it always hovers at 25% now.

Thank you.

00000006.BIN (1.6 MB)

1 Like

To start, try this

Set MOT_HOVER_LEARN parameter to 2 and go fly :slight_smile:

Thank you - that worked. Now I read the docs I see that learning only occurs in flight modes other than Stabilize, which makes sense. Strange I haven’t previously seen such a large initial offset from mid stick after installing previous releases.

Don’t worry. On my racer, before I setup TH_MID like above it would hover with just a touch of the throttle stick (less than 15%) :slight_smile: