AC 3.5.7 RTL Fail

Hi All,

I recently built a custom DJI F450 with the Pixhawk mini (running ArduCopter 3.5.7) and while testing flight modes, I ran into an issue. I was testing AltHold and Loiter modes which worked great. I then switched to RTL and at first the drone did everything it was supposed to (Rise up 1500 cm, fly back to home position at 500 cm/s and loiter above home for 5000 ms - Default RTL settings). Just before it initiated the landing process (my RTL_ALT_FINAL is set to 0 so it automatically lands), there was a GPS glitch and instead of the standard EKF failsafe procedure of landing, it took off almost 250 ft into the air. I was luckily able to switch to Stabilize mode in time and was able to guide the quad back to the ground, but I am not sure why instead of landing, it took off on me.

Unfortunately, my laptop was having issues, so I couldn’t connect to the GCS and get a T-Log, but I do have a dataflash log and here is a screenshot of the Barometer Alt reading with the error messages:

Any help would be much appreciated

Without a dataflash log posted here (.bin) nobody will be able to help you.

I’ve attached the log here

2018-08-12 (854.6 KB)

As usual, heavy vibrations upset EKF and makes altitude hold impossible, causing uncontrollable climb.
Something definitely got loose onboard.