AC 3.2 - No RTL after Radio Failsafe

I had a very disturbing experience a few days ago. One a very routine testflight the X8 conf copter went suddenly in radio failsafe (~289m from pilot) and instead of RTL it started to just…fly around. I have tried both Loiter and RTL number of times before this flight and they both were working. The main question is why it did not RTL?
Some additional info:
*Arducopter 3.2
*X8 conf copter (~17kg)
*Spektrum DX9 + AR10000 (main receiver antenna + 3 satellites) with PPM encoder
*I have been testing different copters in the same spot for over a year, no problems with the spot.
*I have flown over 500m LOS with the same copter and it never lost connection between RX/TX.
About the flight:
I did a forward straight line, stopped and started to come back but on the way back the copter made a sudden movement and started to just fly around. I tried switching between different modes and it seemed that I occasionally had control over the copter (10% of the time). I started running to the copter and tried to pilot it in the same time. After about 3 minutes I somehow had enough control to land it unharmed.
Could someone shed some light on what might have gone wrong?

Log: … 8.log.html