About GPS/Non-GPS Transitions

I set up in accordance to https://ardupilot.org/rover/docs/common-non-gps-to-gps.html. I use GPS as the main source of pos estimation , and extNav (cartographer positioning in the companion computer TX2) as the second data source, but when I did the source switching experiment, EKF was red. When switching to extNAv as the data source, I set EKF origin, but nothing is reflected, and there is no expected car. Is there something I haven’t configured?Any suggestions will be appreciated. This picture shows the print message of my flight controller in the mission planner .


My parameter table is as follows:
rover4_1_dev.param (14.3 KB)

Hi @chaqing,

Thanks for giving 4.1 a try and for reporting back.

I think the VISO_ parameter setup has been missed. It looks like I need to update the ROS+Google Cartographer wiki page so it may be better to follow the T265 setup page.

Basically you just need to set VISO_TYPE = 1 (MAVlink) or 2 (T265)… if Cartographer provides attitude and velocity then I think “2” should work. If it only provides position and/or velocity then use “1”.

Thank you so much. I will try it. :heart:

Sorry to bother you again, I tried to set VISO_TYPE to 1 and 2 respectively, but the results of both are EKF is red, indicating that there is a problem with EKF (but EKF is white when I do non-GPS experiments with 4.0), there are vision_pose_Estimation and / cmd_vel data, why is this? Thank you.

@chaqing,

Good to see that the VISION_POSITION_ESTIMATE messages are being delivered.

You rebooted the autopilot after changing VISO_TYPE parameter?

Maybe set LOG_DISARMED = 1 so it produces logs while disarmed and then move the vehicle around a bit and then download and post the onboard log?

Hi @rmackay9,
You are right! After changing VISO_TYPE, the ardupilot should be rebooted. Now, everything goes well, I will try the automatic switching function next time,thank you very much :grin:
W2S${V5T765L96X1T_82TE

1 Like