About 'Do_Set_ROI_None'

Hi forks,

I got the information that ‘do_set_roi’ is worked with yawing drone for nose to ROI point if MNTx_TYPE is set to 0.
But gimbal control such as ‘pitch = -45 deg’ which is needed for doing ROI, MNTx_Type should be set with non-zero (As my gimbal camera is SIYI A8 min, my ‘MNT1_type = 8’ with connecting Serial3 of FC).
I want doing ROI with yawing drone nose to ROI with gimbal pitch = -45 deg.
(The reason is that, with only ‘Do_set_roi’ , it controls gimbal only and not controls yawing drone, which make the video to display the landing gear.)
In that case ‘Do_set_roi_none’ might be needed with ‘Do_set_roi’. Am I right?
So, I inserted ‘do_set_roi_none’ command in plan profile with ‘unknown’ and ‘197’ command id.
And try to write plan profile to FC but failed.

The error message in mission planner was

스크린샷 2023-09-12 030544

The details is

The version of mission planner is 1.3.80.
And arducopter FW versions of ‘4.4.1 beta1’, ‘4.4.0 (official)’, ‘4.5.0 dev’ ‘4.5.0 dev SITL’ were tested with exact same result.

Test with QGC, the following error displayed.
스크린샷 2023-09-12 181451

Could you anyone tell me what’ wrong?

I just want to find the way for controlling pitch of gimbal with drone nose to ROI whatever the value for ‘MNTx_TYPE’ is. But with serial interface between FC and Gimbal not with AUX/SBUS interface.