A mistake between arduplane and Mission Planner

I’m testing Arduplane 2.74b with Mission Planner 1.2.80. When I tried to set up WP_LOITER_RAD in Mission Planner CONFIG/TUNING Full Parameter List to -80 to have anti-clockwise loiter, it was accepted. Then I changed to FLIGHT PLAN, -80 was displayed in Loiter Radius. After editing flight plan I pressed Write WPs. But when I have a look at CONFIG/TUNING Full Parameter List, WP_LOITER_RAD has changed to 176. I tried with different values like -100, -300, and after Write WPs they have changed to 156 or 212. It looks like the negative values always changed back to values between 0…255 but keeps the relation that 80+176=256, 100+156=256, 300+212=512, so I can conclude that there may be a mistake in declaration of uint8. BTW on the field the loiter direction is always clockwise even when I have changed back in Full Parameter List to -80 after Flight Plan Write WPs. Does any one know the reason?

[color=#004000]Moved to GCS/Mission Planner.
Please post your support requests to the appropriate subforum![/color]

negative loiter radius’s are not currently supported by arduplane

I don’t understand. In ArduPlane code there is a check if loiter radius < 0 then it sets loiter direction = -1, or CCW loiter. If not supported why it does check?

are you entering as part of a mission, or for all loiters

I’ve described the whole data entering process in the post. Yesterday I even tried with Mission Planner 1.2.83, but the result remains the same.