A battery issue? Battery % drops like lead

I’m not sure which ones, so here’s everything that comes up after searching for “batt”:

One thing that looks wrong is that both battery monitors are using the same pin 14. BATT_VOLT_PIN and BATT2_VOLT_PIN should not be the same, try setting one of them to pin 13.

I haven’t tried this yet… Honestly, I’m scared to. Will pin 13 monitor my voltage correctly, even though I’m using Cube orange? Did you also notice that my current pins for each battery monitor are the same (pin 15: Cube Orange) What about those? It seems like changing t he pins would also require re-wiring to the new pin designations? Maybe I do not understand correctly…

What exactly am I doing when I designate a new pin for voltage monitoring? It seems like that is telling the flight controller to monitor a different pin, which is going to be something different, or basically read from a different wire/pin… I’m researching it, but it is not clear to me yet.

What @copilot pointed to you is that you are probably misconfiguring your battery monitor parameters… you can’t assign the same pin for two monitors (considering you have two different monitors).

If you’ve got a Mauch voltage and current sensor why have two different sensors configured in Ardupilot?

I have two Mauch sensors; one for each battery. Exactly this setup:

When I went to configure the Battery Monitors in Mission Planner, for the first battery monitor, there is no option for “Cube Orange,” so I selected (as per instructions at Mauch) “Analog voltage and current.”

For the second battery monitor, “Cube Orange” is what I’ve selected for both Volt Pin and current pin:

Which brings to me to what @BrunoBagarini and @copilot have brought up regarding the volt pin:
I get what you’re saying about specifying the same volt pin for both battery monitors. Before I change it though, I not noticed that I have also specified the same current pin for each monitor. So when I change the volt pin, shouldn’t I also change the current pin for one of the monitors? Otherwise it would be trying to monitor current for both from the same pin, but voltage for each from different pins…? Then how can I be sure that pin 13 is the correct pin, and what pin for current on the second monitor if in fact I should change it. I’m not understanding about the pin assignments. Over at Cubepilot: The Cube Module Overview - CubePilot I’m seeing different pin numbers for each power connection, both connections only having pins1-6, so pins 13, 14, or 15 just are not making sense to me as to what those numbers are relating to exactly, and what I am doing when specifying the pins.

2022-11-28 01_24_42-Mission Planner 1.3.77 build 1.3.8110.38294

I’m thinking I’ve entered my battery monitoring settings incorrectly all the way around, as far as what I should have selected in Mission Planner.

1 Like

OK then !
If you have the two current/voltage sensors plugged into a Sensor Hub, and that into Power 1 - then you effectively only have one current and voltage sensor.
The Mauch instructions say to average the two voltage values supplied, and add the current values supplied.

  • Voltage divider = (Voltage divider sensor 1 + Voltage divider sensor 2) / 2
  • Amp/ Volt = Amp/V Sensor 1 + Amp/V Sensor 2

Put these calculated values into


Disable BATT2 by setting

The backup BEC can still plug into Power2 but doesnt need voltage and current monitoring.

Just for reference, these are the BATT2 pins for Cube Orange


Yep… I read those instructions at one time, but I know when I actually installed and went to configure I forgot all about them and was not factoring the sensor hub into the drone. Forgot all about it, even while trying to solve it. Thank you, thank you.

In case I run into this issue on my next drone, and for anyone else trying to solve the same issue, I like to post the link to what I missed/solution. Those instructions, not to be overlooked, are at:

I think I’m ready for my first test flight (celebration time)

1 Like

Please, don’t forget to follow all instructions here:

For sure. I’ve already gone over it several times, and I will go over it again to be certain. Plus, I’ll check through everything; hardware and software… and I’ll be doing some ground testing before any taking off. I’ve been working on this thing (and a couple others) off and on for about 3 years now, so you could say I’m not in a hurry, nor am I in any hurry to crash it due to not preparing.

1 Like

Actually I spoke too soon. It’s not fixed. I still get my battery percentage dropping at almost 1% per second. This continues until I unplug it. Then when I plug it back in, it’s back at 90%.

My battery works fine on my other copter and does not have the same problem. The .params for it are nearly identical.
(my params:)
s1000 (copter I’m working on): params2022november30newestr7.param (17.6 KB)
s900 (other copter): params30november2022lastr1.param (17.5 KB)

Strangely, now when I try to enable a second battery monitor (only so I can check the [quote=“xfacta, post:9, topic:93518”]
[/quote] settings, Mission Planner goes into a freeze state and I get:

I wouldnt worry about trying to enable the second battery monitor, not sure why MP would freeze up. I would have used the Full Parameter Tree anyway.

In both those sets of parameters you have the low and critical mahr values crazy low!
Around 80% of battery capacity used would be more typical.
Like 20000 x 0.2 (20% remaining) = 4000
Have you checked that BATT_AMP_PERVLT is accurate?

Here’s how to adjust your Amps Per Volt

  • Plug in a fresh battery and do a hover flight for 5 minutes or until you’ve used a signifcant amount of battery capacity
  • Immediately unplug the battery and charge it, note how many mah’s it took to charge. Let’s say that was 1,500 mah
  • Download your log and look at maximum CurrTot. Let’s say it was 1,300 mah
  • Get your existing BATT_AMP_PERVOLT setting from Mission Planner
    With my example numbers, you’d get
    NEW_AMPS_PER_VOLT = 17 x 1,500 / 1,300 = 19.61
  • Set the new value in the BATT_AMP_PERVOLT parameter and save to your copter
  • Fly to check, repeat until you’re happy the new value gives consistent readings

this is different than what is expressed on the calibration wiki by @rmackay9. will this result in similar or better calibration?

Better - calibrating this way gives a surprisingly accurate BATT_AMP_PERVOLT
For the test flights, mainly just hover, you want a constant current draw.

It’s not so bad with a Mauch or other hall sensor where they can measure low currents accurately, but it cant hurt to verify.

1 Like

cool I have always done it the old sketchy way spinning props upside down. Always worried the hell out of me doing it that way. You should maybe add a wiki entry for this method I think the community would greatly benefit from this method it seems much safer than flipping the props and spinning them up.

1 Like

I was only doing that to get the BATT2_CURR_PIN & BATT2_VOLT_PIN to show up. Not having a Battery Monitor2 setup seems to have removed these params. When I search for either, they do not exist in my list of params. I was trying to enable them to check the pins (even though I’m not using them - I thought they could be conflicting if improperly set.)

Thanks - I will update these to something more reasonable.


I can’t sly yet. I can’t even arm. This problem started when I went from a 1 battery system to a 2 battery system, or possibly in the upgrade to ArduCopter 4.3. Before that I was ready to fly.

I just discovered that I’ve not calculated my amps per volt correctly. The instructions at Mauch say to add them, not average them, which is what I did for both the voltage divider and amps per volt.

That was my next point - adding the Amps Per Volt values
It looked suspicious in the params

1 Like

I adjusted the amps/volt, but still… My battery percentage still drops at a rate of about 1% per second. My other copter, configured almost exactly the same, doesn’t have the problem using the same battery. I’ve tried comparing params to find the difference without any luck finding anything.
My params:
S1000 (copter with problem):
params2022november30r11.param (17.6 KB)
s900 (copter without problem):
params30november2022r1.param (17.5 KB)

it could be a faulty item if all parameters are the same