450 Setup Difficulties


after successfully building a 3DR quadcopter, I’m trying to set up a Blade 450 to work with my Pixhawk. I got everything mounted and installed the firmware, did the all calibrations etc.

When I come to setting up the servos, I only get the swashplate servos working. The tail servo is powered on, but I cannot move it with rudder input. The APM does not seem to take any corrective actions, as the heli is just spinning upon spool up.

I power the servo rail through a BEC in Ch8, the tail servo is plugged in into Ch4. I assume channel 4 is working, as when I click reverse in the setup pane, the servo flips over to the other position, but then remains locked there. I also do get a rudder signal from my remote. I set the tail type to servo only.

Any hints? I tried the current and the beta software, same problem.

OK, I solved this problem by erasing or resetting the board. I thought that would be the case when flashing a new firmware type for a different configuration, but you never stop learning :wink:

I also had troubles with the Mission Planner and Win10, which seemed to be inexistant on WinXP. I submitted the bug reports, so I hope they will help.

Now I’ve to figure out, how to start the motor w/o a Channel 8, I only have 7 channels on my RC. I’m still fairly exited tho :smiley: