Servers by jDrones

4-wire cable Sik-radio on Pixhawk 2.1?


(MickeM) #1

Hi,

I have a fully working telemetry-setup with Pixhawk 2.1 and a plane with standard 3DR 100mW 433MHz-radios.

  • The radio on the ground connected to USB.
  • The radio in the plane with the cable that came with the Pixhawk 2.1-kit between the Pixhawk 2.1 and the radio with 6 wires (GND, Vcc, Rx, Tx, CTS, RTS).

But when using another radio in the plane that only have 4 wires (GND, Vcc, Rx, Tx) i dont get it to work. I cant get it tto work if I connect Tx from Pixhawk 2.1 to RX on the radio and Tx from radio to Rx on the Pixhawk 2.1. The radios works if I for example connect them using USB to set NetID.

Question: Is CTS and RTS a must?

Regards
MickeM


(RickyG) #2

CTS and RTS are used when flashing the unit but not for telemetry.
I assume both are on the same netid.
Have you set the ports speed and communication type to Mavlink.


(Amilcar Lucas) #3

If BRD_SERX_RTSCTS is set to on, then CTS/RTS is a must.


(RickyG) #4

I don’t know about that setting as I have never seen it before in Arducopter, but perhaps it’s in a newer version and I am unfamiliar with it.
For telemetry ports used for MAVLink communication you may select to use MAVLink1 by setting the SERIALx_PROTOCOL to “1” or MAVLink2 by setting SERIALx_PROTOCOL to “2”.

SERIALx_BAUD,57

BRD_SER1_RTSCTS and BRD_SER2_RTSCTS parameters allow enabling or disabling flow control on Telem1 and Telem2.

for my current flying machine

SERIAL1_BAUD,57
SERIAL1_PROTOCOL,1
BRD_SER1_RTSCTS,2

Telemetry works great


(MickeM) #5

Well, it works now. What I did? I dont know. I used three other SiK-radios and then back to the ones I tested first which are meant for the plane. All same NetID and other settings. I do not like when I dont do anything and the results differ. Thanks anyway. I have learned a lot anyhow. :slight_smile:


(RickyG) #6

Thats so frustrating. I love it when it works, hate it when I don’t know why it works.

Glad it is, good luck and safe landings.