4-in-1 ESC - direct reading of voltage and amperage

a few days ago, I bridged the 4 servo inputs of my fettec and went through the config again and it worked, I’m happy with the board now.

for anyone setting up a fettec board.

  1. add glue to esc connector
  2. make a correct cable to a betaflight FC
  3. update esc and name each esc output correctly on the windows configurator, web didn’t work.
  4. bridge mot1-4 input and connect it to tx on FC(this can easily be done with a piece of 28awg solid wire on the back of the board.
  5. make sure your arducopter fw has the fettec code, if not build a new one on the website.
  6. assign servo# to 33+
  7. read fettec arducopter doc

thanks to amilcarlucas and Torsten for their patience



I was trying to find an answer to the same question and have just come across this post. Some really useful info here.

In my setup, I have a Speedybee F405-Wing, and a Speedybee 4in1 BLheli_S esc.
The documentation shows the ‘current’ pin of the ESC going to the ‘current’ input on an F405 V3 (not wing), but gives no indication of how it works.

The BLS 50A is designed to be used with the F405V3 (as image shows).
But it must be possible to configure the F405-Wing to take the same ‘Current’ data?

Hello, I am also considering trying the FETTEC ESC 4IN1 - 6S 35A. I want to know if there is any possible drawback of not using a power module and just using the ESC OneWire protocol.
In my case, I am using a holybro Pix32 v5 with a mini carrier board. how can power the FC without using the power module directly from the ESC?

The drawback is that the current consumed by the fc, it’s sensors and any other payloads will be ignored in the ESC telemetry.

Total consumed current = ESC consumed current + FC consumed current + sensors consumed current + Payload consumed current

So total consumed current != ESC consumed current

One other small issue is that the current and voltage levels are a bit noisy

And the FETtec has no integrated BEC, so it will will not give the 5V required to power the FC and it’s sensors.

You can’t. Like most 4-in-1’s it doesn’t have a BEC.

Hi amilcarlucas,
I just bought 2x fettec 35a 4n1 after your recommendation.

I’m facing issue here that cubeorange is unable to start motor on Onewire protocol, no blue led lit up on esc after cube bootup before doing so ive tested these esc on betaflight individual esc signal worked fine.
cube orange with Bdshot FW 4.4.0 arduplane
serial 4 (GPS2 port) is used as mentioned in document , 4 signal bridged to tx & TLM to rx & GND

other thing ive been trying ton get esc’s connect to configurator via betaflightpass through, the configurator unable to read any of esc. I’ve used an h743 fc with connection documented by fettec for BFpassthrouh.
hoping for solution on this to get onewire working with APlane

FETtec ESCs work best using FETec protocol, not BD-shot.
Use standard Cube Orange firmware (ArduPlane 4.4.1), not a -bdshot variant.

1 Like

After changing it to standard Cube+ FW i noticed response on onewire on fettec 35a esc
Currently I’m message as [ FETtec: 4 of 4 ESCs are not running].

if this works fine then im planning of 12s setup for onewire on high range fettec esc’s.
whats ur thought on this, how good will it be?

can u link me down for their higher range esc’s


The wiring is incorrect or the configuration is incorrect. Please post both here

config: cubeorange+ with 4.4.1 arduplane, fettec 35a
for testing of 1 4n1 4 signals parallelly connected to fc TX and TLM to RX of Gps2 port
serial4 = 38
option = 0

esc’s are fresh out of the box.
for getting fettec esc talk to configurator i’ve tired on lux H7 BF4.4.0 , tlm to tx6 & esc 1-4 connected to esc port, esc tlm enabled but no other tlm data then temp.

esc not getting detected at fettec configurator in BF passthrough.

Contact @TeeZee from FETtec

Finally I got Fettec Onewire started working on CubeOrange.
A Big THANKS to @amilcarlucas & @TeeZee for their patience & quick response.

Setting up fettec OneWire:
Adding trailing note to @giraffe note in above discussion

• Flash latest firmware, as of now[1.0.225], ESC firmware must be grater then ver: 1.0.184
• For usnig 2x 4n1 connection: parallel connection of esc signal as per requirement to FC>TX and parallel connection of TLM of both esc to FC>RX . MAX 12 esc supported! on Ardupilot
• ESC id’s to the esc if you are using more than 4 , other esc starting from 5,6…12
• Set SERVO_FTW_MASK properly as per the configuration

1 Like