Servers by jDrones

4.0.1 rc 2 anomalies observed on Cube Orange

Hi

Hope I am posting to the right place. Please advise if not. I took 4.0.1 rc 2 for a test drive this morning an a 1.2 meter Octo. The Octo uses FrSky telemetry. A few unexpected things occurred:

  1. Autotune didn’t work - I could here the tones when engaged, but no autotune - copter just stayed in Alt Hold.

  2. May be related - Loiter didn’t work either. Again, tones from Cube Orange when loiter engaged - then copter gently drifted off on alt and heading.

  3. Occurs on both 4.00 and 4.0.1 rc 2 - current measurements don’t seem to be accurate. They read overall too low with strange spikes that I don’t think are real. Voltage reads fine though. I’m using the ProfiCNC power bricks x 2.

General comments - the copter flew really well. Alt hold worked very well. Pos hold untested. Copter felt quite tight although further tuning needed. All in all a pretty impressive experience!

Cheers, David.

1 Like

Hi David, welcome!

  1. Autotune isn’t it’s own flight mode per se. So when you take off in AltHold, then invoke Autotune, the flight mode is expected to remain in AltHold. However Autotune can be a bit tricky to initiate. Was it windy when you tried? The twitches of the Autotune will only proceed if the sticks on your transmitter are centered. So if it is windy and you have to hold the sticks to keep the drone in place, Autotune will not twitch. It is like this so that you can re-position the drone during Autotune without it also twitching while you are trying to keep it from chopping down that tree it might be headed for (for example)

Make sure your rc has been calibrated, and try again on a calm day that will require minimal correction to maintain position. In some cases, I have had to give the roll stick a tiny little push then let it center itself to get Autotune to start. In extreme cases, you could adjust the stock’s center dead zone size, but that is a last resort.

  1. Do you have a GPS installed? Have you calibrated your compass/mag? Have you done a compass-motor calibration? Are you getting a good GPS lock with a low HDOP value? (you can see this in mission planner even when on the ground).

  2. You are going to have to be way more specific here. What measurements are you talking about?

Edit: @rmackay9 corrected me - Autotune is its own proper flight mode since all the way back to 3.4. See here: 4.0.1 rc 2 anomalies observed on Cube Orange

2 Likes

Hi

  Thanks for the response. Also thanks for the ideas on what the

issue might be. The conditions this morning were very calm -
variable winds - less than 5 knots or nil. Very gentle movement of
the copter with the wind was observed.

  I took off in stabilised, switched to alt hold and initiated

autotune at a safe height. I tried this on four occasions - each
time I did a course correction after about 30 seconds using gentle
inputs. Could it be that I jumped the gun on auto tune
initialising? This sounds likely from your post.

  The RC has been calibrated and I take your point on the roll

stick. I’m using GNSS via a UBblox series 9 Zed F9P. The HDOP
value was fine.

  Your comment addresses a possibility as to why AT didn't

initialise. I noted that loiter mode didn’t seem to work either. I
was pleasantly surprised as to how well it flew on the default
PIDs. Not perfect, but nonetheless very good with minimal
oscillation on the roll axis only.

Cheers

David.

1 Like

G’day David,
could you post a log file? Any analysis is just speculation without that, I’m afraid.

1 Like

Regarding your Cube Orange current sensing, have you selected “8 Cube Orange” as your HW Version on the Battery Monitor tab? In the Full Parameter List the BATT_CURR_PIN value is 15, and BATT_VOLT_PIN is 14 for the Cube Orange.

I’ve noticed that the latest versions of MP will not display and load this parameter on the Battery Monitor tab, but the value is retained when you set it, and looks correct in the Full Parameter List.

I recently had a flight where current was scaled about 25% higher than normal on my Cube Orange after a 4.0 beta update. I’ve flown the vehicle enough to know what to expect. I made sure my HW Version was “8 Cube Orange” and after the update and it has been fine since, but don’t know if this helped.

I usually initiate AutoTune from PHLD, and have had numerous occasions where I forgot the to center the throttle and it just drifts in the wind until I remember - Reminds me of an old song, “My copter’s just drifting in the Wind” :slight_smile:

1 Like

@ekliptiko,

Thanks for providing all this good advice to @David_Malcolm. One correction though is that in recent versions of Copter, AutoTune is it’s own flight mode now so it will appear as AutoTune on the GCS. In old version (Copter-3.4.x?) it was, as you say, not a fully fledged flight mode.

1 Like

Hey Hey,

Thanks Eklipto. The problem was that the throttle stick was not centered. I successfully initiated autotune this morning. Conditions meant that I didn’t finish it - but I’m confident that it will work next time I try!

Thanks for all the help and replies. It provided much food for thought - and solved my problem.

All the best,

David.

3 Likes

Thanks for the correction. TBH - i havent had an autotune problem for a while, so I just didnt think much of it!

I edited my post for future clarity.

1 Like
Servers by jDrones