3rd imu and 2nd mag hardware missing with my builded firmware with code Copter-3.4.2 released

Hi all,
I’m a newbee developer and compiled Copter-3.4.2 released with command “make px4-v2” on windows. My board is pixhawk2, with 3 imus and 2 mags.
After writing firmware into my board and connecting, I met an issue: there is just imu0 and imu1 and mag0 data, imu2 and mag1 data missing. Then I made imu and mag calibration, there is no imu2 and mag1, so I think the board can’t find these hardware.
Then, I writing official firmware 3.4.2 ArduCopter into my board, everything is ok.
Is this compiling issue? Someone can help me? Thanks a lot.


If the official version works then it is probably something you changed in your version. Also, are you sure you are using Copter-3.4.2 and not master?

Hi Francisco Ferreira,
I’m sure I have checked out to Copter-3.4.2 committed by Randy.
At the same time ,I tried compiling master branch, but got the same results.
I built the code with PX4 toolchain (pixhawk_toolchain_installer_latest.exe) from http://ardupilot.org/dev/docs/building-px4-with-make.html on windows 8.1
There may be something wrong?

I’d love to help you but I really don’t have any idea on what can be wrong. Randy uses Windows and he has no issues.

Maybe I made a mistake, but I’m not sure.
I’m always in master branch, then I went to find commit (Copter: 3.4.2 release notes committed by Randy) in the git records. Then I checked out to this commit as my own branch and built it.

Now, I tried to check out to official branch Copter 3.4 and found that there was also commit (Copter 3.4.2 release notes committed by Randy) git record.

Codes got in these two ways will be the same? Maybe the first way result in the wrong issue?

Thanks a lot!

Yes, the code will be the same. If you had an error I could try to help, but you are doing the build without any problem, I can’t see how the sensor detection could be affected.