3DR uBlox/compass: offset tremendously high (z > 1000)


since yesterday I’m experiencing problems with the compass calibration on my 3DR uBlox. It was working fine before. Yesterday, however, I wanted to start my quad but it complained about inconsistent compasses. As usual I went through the calibration process in MP (latest beta) - without much luck though: The compass offsets of the compasses were so high, that Copter 3.3 refuses to arm.

I’ve been reading a lot about what I could do, to localize the problem (EMI etc.) and tried numerous suggestions outlined in the various forums - without luck. Attached are a few pictures of my external compass setup. Note that the mast itself is isolated and the tape which fixes the uBlox isolates the (plastic) cover to the aluminum.

My calibration procedures were the same over and over again:

  • go to a field – far away from possible power sources etc.; I’ve also used different locations, the results are consistent though
  • attach battery
  • connect via telemetry
  • perform calibration process via MP

I’ve also tried doing the same with the Pixhawk just connected/powered via USB - no noticeable differences.
Furthermore, I tried to flash plane and re-flash Copter 3.3.3, without much use either.
I’ve checked the I2C cable, vcc-ground lies at 5V which is normal for Pixhawk, that’s at least what the Internet says.
APM Planner 2 shows the same results, only QGroundControl shows different ones, see below.

Note that there were no noticeable crashes or changes to the system over at least the last two weeks and it worked fine – until now :S.

Here are some offsets:
(external) | (internal) | Timestamp | Comment
371/412/994 | -382/-62/-11 | 17.4.16 12:53 | before (re-) upgrade to 3.3
394/425/987 | -357/-71/20 | 17.4.16 13:06 | after (re-) upgrade to 3.3
274/450/1123 | -373/-72/-20 | 17.4.16 13:45
307/465/1085 | -324/-71/56 | 17.4.16 17:06
294/2/9 | -355/4/-116 | 17.4.16 17:23 | done in QGroundControl - not armable though: Inconsistent Compasses
455/780/1124 | -369/-69/-40 | 17.4.16 17:43
440/780/1116 | #2 failed | 17.4.16 17:49

Any help/hints/ideas would be very much appreciated.


Thanks in advance

Did the mast or some screws near the compass have been magnetised ? using a screwdriver with magnet end ?

In mission planner in status tab, you could see compass reading (mx1, my1, mz1, mx2, my2, mz2) for compass 1 and compass
detach you compass from mast and see if mz value in falling when you are moving away


Thank you for your reply, especially the live view of the compass values in MP helped a lot (yeah, noob, sry :blush:).

Removing it from the mast showed indeed way better values (after setting the offset params manually to 0/0/0). I was really worried that I broke it, but luckily I just need a different mast, still weird that it worked fine before, anyway: thank you :).