3DR Telemetry Radios Not Communicating - Solved

Thought I would add this as I could not find any direct answers when I had this 3DR issue…

I have been using NAZA M for a couple of years now but liked the sound of the extended features of the APM and thought I would give it a try. I purchased the APM 2.6, 3DR Telemetry set and Ublox compass off eBay and got straight into setting them all up as soon as they had arrived.

Following the guides, I got to the 3DR Telemetry stage and updated the firmware on the Ground module, only to find that it would no longer connect/bind with the Air module - very frustrating. Now, there is so much ‘Geek speak’ on telemetry issues and I felt giddy without actually finding a direct solution. However, I guessed that the only way of solving it was to order an FTDI unit as this is the ONLY WAY of connecting/checking the Air module if the modules won’t connect. Glad I did, as the channels and settings were completely different! So, if your modules won’t bind (but the lights flash indicating that they are trying/ready to), try the following;

  1. Buy and FTDI unit. In hindsight I would buy one of these as a general rule when buying the telemetry kit. (got my FTDI232 on eBay for 3.50)
  2. Connect the Ground module in MP - Initial Setup - 3DR, load settings and note everything you see.
  3. Connect the Air module via the FTDI unit. You may need to make up a lead for this - mine uses the same connector as my OSD and all of the outputs are written on the circuit board to assist you.
  4. Again go to Initial Setup-3DR and ‘load settings’. Change everything you can to the exact settings that you recorded from your Ground module earlier and click ‘save’. (you may need to update the firmware first)
  5. Remove the FTDI and connect the Air module to your quad APM as normal and power up, but NOT via the USB. Remember - You cannot connect the USB and Telemetry at the same time; it’s one or the other!
  6. Connect the Ground module to your PC… Both modules should now have solid green lights indication that they have paired. If not, repeat the procedure as you may have missed something or not saved the settings.
    7 If paired, go to the 3DR settings and ‘load settings’, then ‘Save’ settings - Done!

I hope this helps somebody - I initially thought mine were faulty but they were fine in the end. Good Luck

1 Like

The FTDI is only required for the V1 3DR radio. V2 has a built in USB interface on the air and ground modules (there is no difference in air and ground in them)