3DR Radio in Bootloader mode after failed firmware update

I was testing out qgroundcontrol GCS and it managed to automatically try to upload firmware to my 3DR radio without my permission. I wasn’t able to connect to my radio and discovered that the status light was solid red. I clicked around the qgroundcontrol software and noticed that it had attempted to update my firmware and had failed. I can’t get Mission Planner or any other software that I’ve found so far to communicate with the radio Is there a way to reset it or get it out of bootloader mode? I’ve tried sending ATZ command over the COM port, but it doesn’t respond.

Any pointers would be appreciated!

Tried using the uploader.py script as well, but got this error:

python uploader.py --baudrate 115200 --port /dev/ttyUSB0 radio~hm_trp.ihx
uploading to port /dev/ttyUSB0
Connecting to /dev/ttyUSB0
Trying autosync

Failed to get SiK banner
Failed to contact bootloader

mavproxy.py --setup
then type
and hit enter followed by
and see what it says just to make sure its not a stuffed radio.

Thanks, Grant.

ubuntu:~/3dr/MAVProxy> sudo /usr/local/bin/mavproxy.py --setup
WARNING: You should uninstall ModemManager as it conflicts with APM and Pixhawk
Auto-detected serial ports are:
Connecting to /dev/serial/by-id/usb-FTDI_FT231X_USB_UART_DJ00DO0P-if00-port0
Connect /dev/serial/by-id/usb-FTDI_FT231X_USB_UART_DJ00DO0P-if00-port0 source_system=255
Log Directory:
Telemetry log: mav.tlog

I didn’t get any response. The radio shows up on /dev/ttyUSB0.

Is there any way to get the radio out of bootloader mode via shorting pins or something? I know there is a way to get it into bootloader mode. I imagine the radio is half baked right now due to the failure of qgroundcontrol to load the firmware completely.

(The +++ command did work on another radio so my setup is correct.)

After the +++ you must wait until it says OK. So


Your’s doesn’t appear to be saying ok. Make sure you don’t have anything else plugged in (like a pixhawk over USB) and make sure you radio isn’t connected to anything else (like your pixhawk over the 6pin wire).

Otherwise you could try MissionPlanner and the radio setup tool in that. It might have some smarts to sort out a half baked radio.

Thanks, Grant.

See this page on forcing bootloader mode via shorting pins.


Once in bootloader you should be able to upload a firmware via MissionPlanner (its the easiest).

Thanks, Grant.

Yeah, it doesn’t respond with OK. There is no response. Mission Planner and the radio setup tool fail as well.

The light is red already, which should be bootloader mode, but MP will not communicate with it. I think its in some half-baked state. It’d be nice if there was a factory reset. I’ll try the shorting approach again to see if I can get it to be responsive.

Shorting those pins should be boot loader mode. If you can’t get into bootloader mode factory reset wouldn’t be any good to you anyway as it does it via the boot loader as well.

Thanks, Grant.

1 Like

If it is in boot loader mode already, does MP know how to upload without getting responses from the AT commands? It cycles through various modes including bootloader and finally says “failed to identify radio”.

I tried shorting the CTS and Ground pins, but don’t see any difference in the response.


Do you know if shorting the two pins works with v2 of the 3DR radio?

I have a cable where I shorted pins 4 and 6 while I plugged the radio into the USB cord:

Is that correct?

I noticed that the board had “boot” printed on it as well. Am I supposed to short from there instead?

All of the sudden MP worked! Its fixed now! Thanks for your help!

Its the kind of thing where you need to have a few goes to get it to work. Fantastic its now working.

Thanks, Grant.


Hi guys, Same exact thing happened to me. QGC secretly uploaded the firmware and I unplugged it halfway through…oops. Now I’m getting those same messages, Failed to identify radio when uploading firmware or failed to enter command mode when loading settings. LED is solid red whenever powered. Any idea on how you actually fixed it?

Try using Mission Planner to update the firmware. You’ll likely need to try it multiple times for it to work.

Actually it was the shorting of the pins that got it to work, thanks

1 Like

Moral of the story is, apparently, don’t use QGC?

Quietly in the background`

Sounds like a bad thing for any software to do. Same event over a year later…

Good deal. shorting the pins didn’t work for me since it was already stuck in boot loader mode. MP cleared the state somehow after a few retries.

I’ve never liked the “we know what’s good for you” camp, especially when upgrading firmware!

1 Like

hi, I have the same thing happening. I’ve done several different radios with no problem. I have 2 that will load settings but won’t seem to enter firmware update mode. I get different errors but it cant identify the board seems to be the problem. I can get the solid red led by using at&update but it still won’t load firmware. it doesn’t even get to the point to choose the firmware file which would be “radio~hm_trp.ihx” oh, these boards do not have CTS pins so I can’t enter bootloader mode by shorting it.
any ideas? can I update fw in terminal? if so does anyone know the command?