3dr radio bad(low) rssi

since some weeks i have suddenly trouble with my 433mhz original 3dr radio. the version where both modules are the same and which comes with an usb adapter cable to connect to usb (computer/handy).

i lost my link to copter if they is only a few(10-15) meters away from my groundstation. this problem happens after i change my apm2.6 against a new apm2.6 because an blown 3.3voltage regulator. imo, since i using the new apm the rssi is bad. before changing the apm my 3dr radio was adjusted to 11db and i never had signal problems. because the new problems i increase this value to 20db maximum. but nothing happens. bad signal and link lost after a few meters:(.

what goes wrong here?

in moment i am a little bit frustrated because many hardware problems. i switch 4 month ago to apm and his products. my first apm2.6 have an broken barometer (replaced without trouble, super support from 3dr robotics). the second run only 1 ore 2 weeks and ended with a blown 3.3v regulator. and now my 3dr radio is not working any-more:). all products are original from 3dr robotics. no cheap clones or so on.

some more tests today,

  1. i measured the input voltage from bec against ripple and spiks(peaks). nothing here. super stable at 5.3V.
    only a very small ripple caused by switching regulator from bec. but this is normal. i have no servos connected to my apm or generally to the bec which powerd my apm. so, here are no problems with ripple caused by digital servos.

  2. i try out my old apm with blown 3.3V regulator. no difference to result. connection lost after distance to ground-station is bigger than 20 meters. so this is not the problem. like i describe in my post, that i noticed the problem after changing the broken apm against a new one.

  3. testing different devices and groundstations. no changes. computer/handy/tablet; mission planner/apm_planner2/droidplanner/andropilot . each time the same result. low rssi and connection lost.

  4. changing the small telemetry connection cable between apm and 3dr radio against an other. no changes in result. uuaahhh!

so imo, something is broken in one of my 3d radios:(.
annoying, because all this stuff is only a few month old:(. and run maybe three to five hours at all. currently i feel that i completely waste my time and my money.

need help here to find out the problem.

Hi wolke,

Try to reset to defaults both radios and to re-flash the firmware using mission planner.

If this doesn’t work contact help@3drobotics.com as you said maybe one of your radios is broken.

thx. i try it. resetting both radios and re-flashing firmware on both radios. no change at all. low rssi and connection lost after a few meters. next days i will contact 3dr robotics. today i also tape my oscilloscope probe on my copter to check bec ripple while esc 's run my motors(mounted props). but nothing wrong here. stable 5.3V from bec with a constant very low or imo normal ripple for an switching regulator. for me it looks that apm is powered well. in past i have similar problems with an telemetry receiver on my t-rex 500. here the range problem was caused by an faulty bec which produce strong ripple if motor consumed current. that’s why i have my eyes at firstly on apm vcc power line. maybe monkey business. but i am a little bit paranoid :slight_smile: and a double checker.


I’ve got exactly the same problem with my 433 set, its happened twice in a row. New set lasts for a few days then suddenly the signal drops and I only get a few meters at best. I’ve tried everything as mentioned above to fix it so I’m thinking its a hardware issue. Strange that exactly the same thing would happen to two sets and so quickly. I’m no expert but something must be zapping them??? Maybe the same thing I guess. I’m connecting to a 3DR Iris with DroidPlanner 2 on a Google Nexus v2.


I had the same problem with my first 433 3DR radios and, after a lot of tests and request, it was simply a problem with original antenas (one of them was broken -the signal wire inside the rubber- ) and the problem was resolved just changing the antenna for a new one.



I’ve got exactly the same problem with my 433 radios. Only been used for a couple of hours and now won’t reach more than a few meters. Looks like this is a common problem :frowning:

Thanks osmunda for the tip, i’ll try ordering a new aerial and trying that before having to go through an RMA from Europe to 3DR in the US.

Is there any particular aerial that I need to get?


Also you could double check if the Tx Power is set to the maximum, is easy to move it when you try to change the Net ID.

Hi, I’ve tried firmware update and reset parameters, no improvement. I tried taking the plastic tube ends off each radio to check the internal wire, it all looks OK and they don’t appear to be loose - a firm tug with no give.

This is also being followed here:
diydrones.com/forum/topics/only- … 400&page=3

Interesting that the clones are using SMA connectors. I imagine this is because they seem to be much more common - it’s near on impossible to find suitable antennas of any kind with RP-SMA female connectors - male SMAs are ten a penny.