3DR Power Module (calibrated): Battery failsafe triggered very early

I’ve performed the battery monitor calibration as outlined by Randy here, so first I calibrated the voltage and then the current.

My problem now (and the thing why I even got into the calibration topic) is, that the (calculated) voltage drops below 10.5 V very early (3S LiPo, 3200 mAh), and with early I mean a takeoff of about 1 m height and hovering there, with a full battery.

So what I did is I observed the voltage during the calibration process and I took snapshots of the voltage/current measured with my meters and with the PixHawk/MP.

Snapshot 1:
Multimeter readings: 11.55V @ 6.91A
MP: 10.99V @ 7.02A
Delta: 0.56V, -0.09A

Snapshot 2:
Multimeter readings: 11.45V @ 9.62A
MP: 10.61958V @ 9.7A
Delta: 0.83V, -0.08A

And I let the quad idling around, with a voltmeter attached, and the voltage displayed in MP matches the one on the meter.

Now my questions:

As far as I got it, the power module is just a shunt resistor, so once the voltage should be calibrated, the calculated voltage should be right, even under (heavy) load, right? This would mean that the volt meter is too sloppy with detecting the changes.

I’m just confused that calibrating with a full battery and drawing 13 A for it for ~1 minute already triggered the battery failsafe.

Any hints would be appreciated, thanks.

No hints here. I have the same issue. I calibrate the sensor at rest and it’s ok. Under load, however, it under-reports badly. So, I have purchased one of the alternative power modules (the Mauch Electronic) that uses a hall-effect sensor. Haven’t installed it yet but hope to this week. I hear this one is much more accurate while under load.

I would review the logs from the flight as it records the voltage and current as you fly. If the reading are correct they should show as such. What can happen though is if the battery gets old the internal resistance of the battery goes way up and under load the voltage will drop by a couple of volts causing premature failsafe conditions. This will show up in the logs so have a look or past a link here from google drive or one drive.


Ou at least the specs read quite well, so this one shouldn’t report false readings, hopefully. Would be interesting to hear some feedback/recommendations.

What I’ve done now is take a few more of those snapshots and I figured out a discrepancy from the measured values to the one calculated from the power monitor of up to 1.2 V. Then I tried to raise the idle voltage by 0.8 V and looked how the measurements match (under hovering/heavy load) way better, even though the idle voltage is now way off, of course. I’m not sure if I do more harm by this than any good, but I trust my voltage/current meters a bit more than this battery monitor.

Thank you for your response, here are two logs just after voltage calibration 1 and 2. I’m quite new to all this, so I don’t have much comparisons to other readings (yet), so maybe you have some valuable comment, would be great :).

To the age of the battery: I got it from my University, so i can’t really say how old it actually is, but new batteries are on the way and I’m really curios to compare how the battery monitor works with these.

Thank you

Looks like a very bad battery. I can see from the graph that it starts out at 12.5 volts and once you take off in Stabilize mode the voltage drops to 11 volts and then shortly after that drops to 9.7 volts which triggers a fail safe. When you land the battery voltages jumps back up to 12 volts so that would indicate a high internal resistance or too small a battery for the job.

To view the graph yourself just open Mission Planner and from the HUD screen select Data Flash logs and then Review a log. Make this screen full size and in the center pull down menu pick the Battery Issues option and you can see the battery voltage drop as throttle goes up.

Copter is drawing about 18 amps.


Thank you Mike,

yeah, I discovered these logs as well, that’s why I came to the whole calibration process in first place. What’s still confusing me though is the fact that the volt meter under the same load does not show the same readings (off by ~1V under hoovering load, ~1.2V under full load). I also tried to keep the current quite stead, so that the (mb sloppy) meter has time to adjust.

But yes, I will give it a try with a new battery soon, once it arrives.
I’ll report back with new measurements then, I’m quite curious already.

Thank you for your help and expertise

I have the same issue with 2 PM items and about 5 batteries of different quality. First PM item has mentioned issue really bad, the difference was about 1.6V. Second PM item is definitely better, it has just about 1.2V drop on load.

So I pretty sure the root cause of issue is not in the battery. It definitely looks like voltage drop in PM under load.

Gents, I’m having the same issue. Have any of you reached any new conckusions?


1 Like

im having the same issue too!! Did someone figure this out?

Calibrate the voltage sensor at the lowest voltage you expect to see.
For example with a 3 cell Lipo system find a very discharged battery or even a 2 cell, or bench power supply, and set the voltage to about 9.0, measure it accurately and calibrate for that in MissionPlanner.

For current measurement, you can fly and compare logged mAhr current usage to how much mAhr you charger puts back into the battery. There’s a formula and procedure for that, let me know if you need help.

Use this spreadsheet or the MissionPlanner Initial Parameters plug-in by pressing Alt A to set the correct battery voltage parameters for arming, failsafe and motor/battery PID scaling.