3DR Pixawk bad ahrs

I received a new 3DR pixhawk in September and only just got around to installing it.

It fails everytime on the accelerometers calibration and keeps telling me bad ahrs.

I have contacted the supplier robotshop who said it only has a three month warranty and is now discontinued! Not heard back from 3DR yet.

Is this a faulty board as everything else seems to work?

Having owned an APM 1, 2, 2.5 and currently have 2 x 2.6’s which were ok and the latest two are fine, this pixhawk is puzzling.

I get that all of the time.
What firmware are you using? What GPS? are you using the external compass?
I am using ardurover latest with a Ublox 7n gps. If I am inside I get a GPS lock but still get the bad AHRS error message in MP. When I am outside with clear sky view the bad AHRS warning goes away.
If you haven’t already, put your vehicle outside with a clear view to the sky, meaning no overhead structure, clouds are ok, and see if you get better results?


I can’t even get passed the accelerometers initial calibration! I am using octocopter firmware, latest from the mission planner. I tried others too, but they all fail.

Are you using external compass?

I’m not the best person to give advice due to lack of experience.
How are you calibrating, I mean in the copter OTA or via USB connection?

Yes using an external compass/gps module that it came with and using USB to calibrate.

Something is not right as it has just calibrated correctly, but keeps telling me the RC has not been calibrated, even when it has. Using just the spektrum remote receiver seemed to work, seems it does not like the ppm encoder for some reason.

Oh well more playing around needed. :confused:

Great to hear it calibrated the accelerometers.

Sorry I can’t help with the RC as I dont use one. I use MP/radio telemetry with a joystick.

Best of luck.