3dr Iris+ voltage problem

Hello, thank you very much for reading my post.

I need help with a 3DR iris+ that has a possible voltage issue.
I bought this drone with this fault and with more than 20 years of experience repairing computers and recovering data, I said to myself: how difficult can it be?

When connecting the battery the led turns on and off in yellow, when pressing the button to arm the led remained the same, when reviewing the Mission Planner messages I found that it indicated: GPS 2: was not found. So I had to disarm the drone, check that everything was well connected and found that there is only one GPS module installed. So I had to go into settings where I found there were 3 compasses enabled, disable number 3 and disable GPS 2 and did the compass calibration, with this the GPS 2 error disappeared.

With this, when connecting the battery and after pressing the button, the LED now flashes green, but I cannot assemble the motors.

When checking Mission Planner, the Preflight indicates that the battery level is 10.34 volts, the station indicates that the voltage is 10.34 volts with 99 mAh (if it is left connected for a while, this value increases). So I got a battery tester, the battery indicates that it has 12.5 volts, and the 3 cells have more than 4 volts each, unfortunately I don’t have an ammeter to check the amps.

I tried another battery, check that the level of the cells is ok and the same thing happens.

Since I use 1.2 volt rechargeable AA batteries, I thought that these 10.34 volts corresponded to the voltage level in the transmitter batteries, but when checking the manual it indicates that the buzzer activates when the voltage is lower than 8.5 volts.

What do you recommend I check? Do you recommend testing the transmitter with 1.5 volt batteries? Do I have a voltage board problem and need to repair a component or replace the board? Or do you think it is due to a configuration problem within the mission planner configuration?

Thank you very much for your help


  • Backup your parameters.
  • Update the firmware to ArduCopter 4.2.3.
  • Reset all parameters to default.
  • Do the initial mandatory tuning
  • Tune the notch filter
  • Tune the PIDs

Hello @zabandija,
I have an IRIS+ that has been totally updated, and have worked with another pilot to get
his IRIS+ flying as well. Start from scratch, and do the entire setup as outlined above. The latest Arducopter flies fine on the IRIS. Be aware that the FC in your original bird most likely has the 1MB memory limitation; unless you know this isn’t the case, use the firmware ‘Pixhawk-1 MB Limitation’ when you download.

Best luck with your IRIS+…


First of all, thank you for taking the time to read my post and help me solve my problem.
I am going to follow your instructions and hope this will fix the problem.
In case the voltage problem continues after updating to arducopter 4.2.3, what do you recommend I check?

Thank you very much for your help


We’ll cross that bridge when we get there, not before :slight_smile:


Following the instructions of @amilcarlucas, the firmware has already been updated to version 4.2.3, all the parameters have been reset to default, and the initial mandatory tuning has been carried out.

You were right @amilcarlucas, with this, although the LED is still not solid green, I did a test and was able to correctly assemble the motors.

It remains for me to perform synchronizing the notch filter and synchronizing the PIDs.

As I am new to this and have never done it before, is there a guide that you recommend that explains the processes that I must carry out?

Thank you very much for your help.

The best way is to just follow the instructions:


Hello @zabandija - I wonder if you were able to fly the IRIS+ ?