3DR FS-TH9X controller not Binding

I recently bought an X8R receiver and I tried to bind it to my FS-TH9X controller with a DJT module, but it does not work. I do not know if the 3DR software inside the controller is affecting in some way. I searched that I had to configure some parameters and all of that in the controller, but all info on how to do it just does not exists anymore.

I have my X8R in mode 1, bot switchs down on my DJT. I am using a Pixhawk 1, but I do not know if I have to configure something there too. HELP :C

You need to put a jumper on the x8r to enable d8 mode its in the manual.

I already did. The 3DR controller has 3 options: PPM, PPM16 and PPMsim. I tried all of them.

Fun with Frsky… My guess: The X8R Rx you bought would have the 2.1.0 firmware and dinosaurs roamed the earth when the latest, and only, DJT firmware came out. Try flashing the Rx to the old firmware from the Frsky X8R download page and click the “not compatible with v2.x.x” link.

1 Like

I will try that. I suppose I need to buy that adapter to connect it to my computer, right?

Yes, unless you know someone with a Frsky Tx. Or Radiomaster and Jumper probably but I’m not sure of the later,

what exactly did you do to bind the receiver to the radio module? your frsky module is bound to the receiver by holding the bind button on the module and switching it on, it should emit a constant beeping sound. then with the channel 7 and 8 pins connected with a jumper on the x8r receiver, power it on and the transmitter module should stop beeping. turn both off and on again and it should be bound.

The beeping emits, but it does not bind. I had de X8R in Mode 1. I followed that both swithces in the DJT Module are down, and holding the button while turning it on.