30min+ to download prams

Hi everyone,
Firstly I know this is not directly a topic for this forum but I seem top get a much faster response here that in the hardware forum, so sorry in advance:

I am using RFD868+ (baud rate 57600, air speed 64, 50 channel hop, duty cycle 100, ECC checked, Mavlink checked, two antennas on each end, do not have RTS/CTS checked, running SIK 1.12 on both), AMP 2.6 with Missions Planner. When I hit connect the it takes over 30min for the “Getting Prams” to complete.
In the past I have been using 3DR radios and the “Getting Prams” took less than a min.
I am bench testing so I have the power setting at 10 with 15metres and two concrete walls between. I have tried higher and lower settings but it’s the same.
Any one know why it is taking so long to Down load the prams? Fairly Frustrating!
Thanks in advance,

If you are using MP, what version are you using?
What version of the ArduPilot firmware are you using?
Are you using the RFD transceivers at both ends?
I had this problem once with the 3DR Radios and it turned out to be a ArduPilot firmware issue.

I’m not certain if this is still true but previously when you upgraded MP it didn’t upgrade the USB drivers along with it. I’d uninstall MP completely, then reinstall the latest version and try again. Those RFD868 radios are quite new so probably require relatively new drivers.
Thanks, Grant.

Hi Guy’s
Thanks for you speedy reply.
I’m using MP 1.3.38 build 1.1.5983.12141 just updated today.
Will check the Rover firmware and update.
Yes I am using RFD’S on both ends.
Will uninstall and reinstall as per your instructions now.
I’ll report back as soon as its all complete.

Should the ECC box be checked in the modem config?
What is ECC?

Thanks again,

ECC = Error Correcting Code.
As long as both radios are RFDs you can check the ECC box.

to diagnose this we need the tlog from the logs directory in MissionPlanner. That should tell us weather it is a MP or ArduPIlot issue

Richard, I’ll check my settings in an a hour or 2. I’ve had great luck with the RFD’s both with an APM 2.5 and Pixhawk. I do think that I’m using SIK 1.9 though.


David R. Boulanger

Richard, I am using 1.9. I’ll attach a screenshot of my settings.


David R. Boulanger

Guy’s thanks so much for your help Great support!
@TCIII: Thank you I tried both with and without Seppo gave me some leads to follow ECC, Op Resend etc but nothing seemed to make a difference.
@tridge: thanks also, please find the tlogs attached. I am not that familiar with handling tlogs I found these in the program files for Mission planner under Logs :slight_smile: hope thats what you need, if not let me know and I’ll find it.
@David_Boulanger: my settings in the field are exact as yours. While I’m bench testing I have the tx power tuned down.
Cheers guys,
RS2016-05-25 20-06-54.tlog (460.0 KB)

2016-05-25 20-06-54.tlog (460.0 KB)
Ok one files was too big but here is the most recent. If thats not what you need let me know and I’ll post it in my drop box?

Just wanted to mention that I have updated MP and the FTDI drivers upon advice.

Richard, One more thing and then I will shut up. A Tx power of 10 is roughly 10mw I believe. A setting of 20 would be 100mw which is the stock 3dr radio setting of 100mw. I don’t know if 10 mw is enough to penetrate a couple of concrete walls. Hope you figure this out.


David R. Boulanger

David thanks for that, useful to know>

I have tried 4,6,8,16,20, &30 with all results with in 1min of each other.

I will swith over to the 3DR to see if I still have the previous performance of 1-2 min as I had before.



it looks like the UART send buffer on the aircraft side is filling up and it is unable to send PARAM_VALUE messages. Unfortunately as this is an APM2 board we are not doing any new firmware releases (we stopped APM2 releases a long time ago).
Can you also try it on a Pixhawk?

Unfortunately I don’t have a pixhawk at the moment. I will order one in the next seek or so, not only for this issue but also as the new rover firmware rover 3.0 does not support APM boards. I understand the reasoning behind that but from an economical point it is a bit of a shame as I have two apm boards that will be effectively redundant at USD$ 100. a pop (back in the day). But after saying that I am keen to move on to the Pixhawk for multiple reasons.
One question why would this be happening with the RFD radios and not the 3DR radios? Is there anyway I can improve it’s performance in the mean time?

the RFD900 and 3DR radios should perform the same at short range, unless there is a bug.
Once you are on a pixhawk if you still have issues let me know.

Ok I finally have time to order a Pix hawk and all my local (internet) stores are out of stock :-((( HK has a Pixhawk clone but I’m not really a big fan of clones. Can anyone say if the clone is good/bad?


Or should I just bite the bullet and order from 3DR and pay the same price as the pixhawk for the shipping?

I have four different radios (2 HK 500mw and 2 3DR V2…also have unbranded) and for some reason cannot get any range. I tried several different antennae, settings in MP…really has me stumped.

In the past it would get strong signals well over 1000 ft. away while connected to a PC with the radio sitting on a chair in the window.

Now I’m lucky to get 50 ft.

@slimething - your hijacking this thread. You should create a new topic.
I suspect you have powered on your radios without their antenna and thus blown the output amplifier if your no longer getting any range. Never turn a radio on without having its antenna connected.
Thanks, Grant.