Servers by jDrones

3 minute hover test, first VTOL, log review


(Chad Frazer) #1

I just completed my first successful hover test of a custom made Slowstick, can anyone take a look at my logs and tell me anything they see wrong?

Problems:

  1. Aircraft was in QLoiter mode but drifted 18 feet away and required manual input to return back to loiter positions, it acted like it was in Qstabilize mode.
  2. Altitude drift occurred, at landing -6 feet was reported. zero feet at startup, no calibration was performed at startup
  3. Battery is an LiHV 3000maH with 10C discharge, battery voltage at end was 9.9v, in a few minutes the voltage was back up to 13.05. I know batteries do this, but it’s a bit much on the self recharge/balance act?!?

What I think is good:

  1. Vibes are very good
  2. Hover throttle is about 50% if I understand it correctly

Don’t know:

  1. how accurate the voltage reading is, I’ve calibrated it at mid voltage as confirmed by a mulitmeter but I don’t think its accurate
  2. Don’t know how accurate current draw that is being reported via telemetry is.

If anyone can suss out more details or more advice on setup i’d appreciate it!

Takeoff mode was Qloiter and it remained in Qloiter the hole flight, the aircraft was allowed to “soak” for about 5 minutes before flight.

Link to the .BIN file: https://drive.google.com/open?id=1k4rRwyT3Kd8XxEXAUpatfKvLTBrPAah5

Why is such a short flight time generating a 75mb .BIN file?


(cala2) #2

What is your vtol batt consumption?


(Chad Frazer) #3

looks like I have a 40-45 amp hover, aircraft weighs about 1425g.
Battery current total has max of 80, mean of 32.


(cala2) #4

If you have a higher C batt try it, I hope your batt is too low C for that compsumption


(Chad Frazer) #5

I totally agree Cala, I put on order a lihv 4000 with 12c rating which should be ok for hover and a moderate takeoff. I normally don’t push batteries like this but for vtol it makes sense to do so.


(Chad Frazer) #6

I am still puzzled by the way it would not stay in one location with QLoiter mode on…


(cala2) #7

If you don’t have enought energy everything can fail so difficult to see for another issue. Try to go higher c with that consumption.


(Chad Frazer) #8

So the LiHV battery was at 13.05 yesterday which I know is a lie so I let it stabilize overnight (12 hours?). This morning it was about 10V which is what I’d expect it to be.

After charging that battery took 3050maH. I also know that the time in air was about 3 minutes and 20 seconds, give or take a few seconds. That means when all is said and done my hover burns about 1 amp per minute out of the bird.

Doing the math means that the current draw, on average was 3050maH divided by (3*60 plus 20sec) which comes out to a 15.25maH/sec burn rate on average for a three minute hover.

Multiply 15.25maH/sec by 60 seconds that should give me the per minute of amps used according to the battery’s viewpoint which is 915maH/minute or .915 amps/minute burn. So it’s looking like the amperage calibration is very close, good enough for a short duration electric aircraft.


(Chad Frazer) #9

More testing:

It is looking like the voltage calibration is correct. Aircraft is still not holding GPS position with 20-22 sats locked and an HDOP of less than one (avg of .5). Switching back into Qloiter mode after the GPS has had time to get a better lock (and thus updating the hold here position) had no effect.

Bigger battery was tried:
LIHV 3S, 4000maH, 12C, which should give continuous of 48amps. Hover again produced a 40-50amp drain. Motor forward hold assist (Q_VFWD_ASSIST) did kick in for first heavier battery testing. I turned it off for the second heavy battery testing but it would still not hold position.

LIHV drops from 13.05V (charged to the full 4.35V/cell) when plugged in down to almost 9V or less after just 10 seconds of hover. This is most likely due to too heavy of a pull from the motors. Will get a bigger battery.

CG for this aircraft has improved, it is now about 1/4in from the ideal 30% MAC of the wing.

Upon revisiting the motor specs they will draw a max of about 20 amps each to produce up to 6lbs of thrust. If hover is about 50% then the amp draw should be close to 40amps. If motor assist comes on the pull will add another 1-10amps, so in short I need to get an even higher C rated battery.

Will order a higher C rated battery for 5th test.


(Greg Covey) #10

Hi Chad,

I didn’t get to download your log file over the weekend and the link is locked out from work. I wanted to ask you how other modes like like QSTABILIZE and QHOVER worked?

If QSTABILIZE works (no BARO and no GPS) so that you have reasonable control with the sticks and the throttle is around 40%-60% then try QHOVER mode which adds BARO and desensitizes the throttle stick. You can typically leave it around mid-throttle.

If these modes work then test your yaw control. Can you turn the vehicle 90 degrees or 180 degrees? Does the direction match the HUD on Mission Planner? Are you using multiple compasses?

From the Wiki:

A good GPS lock, low magnetic interference on the compass and low vibrations are all important in achieving good loiter performance.

It sounds like you have a good compass lock. Vibrations are easy to check from the log. Details are here.

If your vibrations are reasonable and you are using multiple compasses, try disabling all except for the one on your GPS module. This should be a good start to zero in on the issue.

Good luck!


(Chad Frazer) #11

Howdy Greg!
I have not tried any other mode than Qloiter yet. The direction indication on the GCS does match the heading of the aircraft. I also have good yaw control. I will try Qstabilize soon as well as QHover. I have one compass marked as primary and a second that has green values. I fixed the compass problem by moving components around so that I could point the compass forward (just like the pixhawk 2.1 is). I know I should be able to change the compass orientation but apparently that was causing my problem.


(Chad Frazer) #12

Test 5:

I now have a 25C, 4000maH 3S battery, which can handle a continuous output of 25C *4amps=100amps. I can confirm that my hover amperage is 40-45. Using about 60 amps I could get this bird to save fixed wing mode in less than 20 seconds.

As for the not being able to hold position I trimmed my transmitter 3 clicks pitch down (or forward since it is a quad in this mode). This put the bird rock solid in position. I can only assume this means that my “level” calibration must be off. I also know that the VTOL booms are one inch forward of where the aircraft balances on the wings which might be what is generating the need to give the bird a forward trim. I am unable to move those VTOL booms as they are glued to a wooden wing.

A 4000maH battery gave me 4:59 worth of test time from a full charge.
I am re calibrating the voltage and amperage sensors as they can’t be correct. They can’t be correct because the new battery can more than handle the load put on it and yet the voltage immediately drops to about 9-10V. At this point I also don’t trust the amp readings either.

Question: How do I get my forward trim back to zero and still effect a rock solid position hold?


(Greg Covey) #13

Save Trim and Auto Trim

If these are Copter-only features, then try centering your trims, recal the radio, and do the single axis level calibration in Mission Planner.


(Chad Frazer) #14

Test 6:

Auto Analysis from log:
Log File C:\Users\thear\AppData\Local\Temp\tmpFC60.tmp.log
Size (kb) 118892.49609375
No of lines 1166908
Duration 0:06:26
Vehicletype ArduPlane
Firmware Version V3.9.4
Firmware Hash 7e37f2b6
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = NA -
Test: Brownout = GOOD -
Test: Compass = GOOD - mag_field interference within limits (10.84%)
Max mag field length (574.34) > recommended (550.00)

Test: Dupe Log Data = GOOD -
Test: Empty = FAIL - Empty log? Throttle never above 20%
Test: Event/Failsafe = GOOD -
Test: GPS = GOOD -
Test: IMU Mismatch = GOOD - (Mismatch: 0.29, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = NA -
Test: NaNs = GOOD -
Test: OpticalFlow = FAIL - FAIL: no optical flow data

Test: Parameters = GOOD -
Test: PM = NA -
Test: Pitch/Roll = NA -
Test: Thrust = NA -
Test: VCC = UNKNOWN - No CURR log data

The bird does have a problem with holding its heading but responds well to all control inputs.

I’m thinking I might have the weather veining option on (which I was sure I turned off).

Overall though, I believe this setup is good enough to use as a takeoff and landing system.