Servers by jDrones

3.8.2 Upgrade upsets ESC


(mpjf01) #1

Upgrade from 3.7.1 to 3.8.2. ESC beeps continuously when safety switch is pressed. ESC documentation (Turnigy Plush) suggests that this is because the battery voltage is either too high or too low. The actual voltage is 12.6V.. The ESC worked fine before the upgrade and works fine when connected directly to a servo tester. The throttle is Channel 1 in this model, the RCMAP_THROTTLE is 3, SERVO1_FUNCTION is 70. The ESC calibration routine in Mission Planner gives on odd message (top half of screen) about the firmware version needing to be greater than version 3.3 of something, and the bottom half of this screen is inactive. Does anyone have any advice about how I might get this motor to run please?


(Kikislater) #2

Simple adjust servo3_min servo3_max and rc3min rc3max.


(mpjf01) #3

I assume you mean adjust the parameters associated with the throttle channel rather than the elevator? Do you have any suggestions regarding whether I should adjust the servo or the rc parameters first, max or min first, increase or reduce the range?


(lucamax) #4

I would do the Esc calibraton the old way without the Autopilot board but rather with the receiver .


(mpjf01) #5

I have done that already as part of the separate test with the stand alone receiver. As I have said, all worked fine with the earlier firmware version earlier today as well.


(Kikislater) #6

Yes esc calibration does nothing here.
What is your rc3 min,max,trim before upgrade and new rc1 min,max,trim & servo1 min max trim


(lucamax) #7

Open Mission Planner , "Tuning" check box, click on the graph that will appear and select throttle channel, input and output in Arm and Disarm status.


(mpjf01) #8

After upgrade.

RC1_DZ 30
Min 1055
Max 1895
Reverse 0
Trim 1060

Old values not kept.


(Kikislater) #9

Give rc1 and servo1 please ! Are they same ?
If you have a log or tlog, you could extract param


(mpjf01) #10

Function 70
Max 1895
Min 1092
Rev 0
Trim 1092

There's several of us have been trying to work out this problem all day but we have now returned to our respective homes and the FC is at one of the other houses - so getting information is time consuming. Sorry for the delays.


(Kikislater) #11

Lower servo 1 value like this :

RC1_MIN 1055
RC1_MAX 1895
RC1_TRIM 1060

SERVO1_MIN 1055
SERVO1_MAX 1895
SERVO1_TRIM 1060

If you don't have same value at low throttle, esc won't initialise


(David) #12

Hello Gents,

I am workiing an converting a FireFly6 to Arduplane and have a couple questions about ESC settings.

Here are my values for RC3-8 and servo 3-8:

RC3_MIN 982 SERVO3_MIN 1000
RC3_MAX 2006 SERVO3_MAX 1900
RC3_TRIM 982 SERVO3_TRIM 1500
RC4_MIN 982 SERVO4_MIN 1000
RC4_MAX 2006 SERVO4_MAX 1900
RC4_TRIM 1494 SERVO4_TRIM 1500
RC5_MIN 982 SERVO5_MIN 1000
RC5_MAX 2006 SERVO5_MAX 1900
RC5_TRIM 982 SERVO5_TRIM 1500
RC6_MIN 982 SERVO6_MIN 1000
RC6_MAX 2006 SERVO6_MAX 1900
RC6_TRIM 982 SERVO6_TRIM 1500
RC7_MIN 982 SERVO7_MIN 1000
RC7_MAX 2006 SERVO7_MAX 1900
RC7_TRIM 982 SERVO7_TRIM 1500
RC8_MIN 1084 SERVO8_MIN 1000
RC8_MAX 1904 SERVO8_MAX 1900
RC8_TRIM 1084 SERVO8_TRIM 1500

Should the trim values for the servo match the RC trim values? And should all the RC_x Min, Max and Trim be the same for each channel?

Any insight is appreciated.

Thanks

David


(mpjf01) #13

Setting the values the same did fix the problem, now the ESC works normally. Would there be a case for adding a comment to this effect to the Wiki, it might help if anyone else has the same issue.

Thank you very much for the assistance. Cheers.


(Kikislater) #14

Tridge wrote a tuto on ardupilot doc modification. I had same problem, that's why I answered you. I think problem was during upgrade. As tridge already answer, parameters should be converted to new version but not. I crash a skywalker like that, but not too much damage : servo 4 was not converted and so rudder was reverse but only in auto and fbwa.
How did you upgrade ? Double check params is needed because it's a major version and unfortunately parameters conversion does not seem to work every time...


(mpjf01) #15

I received a notification in Mission Planner that an upgrade was available so I read the release notes. I was aware of the need to recheck everything after the upgrade and did so, but did not read anywhere that the RC and Servo parameter values for throttle should be the same - so I did not check to see that they were. The Servo parameters were completely new to me as I did not upgrade to earlier versions of 3.8. My understanding of them from the release notes is that they specify how the outputs to the servos should be configured. I still haven't figured out how to reverse the elevator compensation in auto modes, I cannot see how a single parameter can be used to simultaneously define the direction (say) that a control should move and the direction that its automatic compensatory control should move unless there is a fixed connection between them, which in my case at least there appears not be. Obviously I cannot fly the aircraft until I figure this out.