3.5rc8 logging fail

Just loaded in rc8 on my small quad (pixhawk2) and my large hex (pixhawk2). Quad flies very well with no issues in all modes tested. Hex will not arm with a logging fail. Reverted back to rc7 and all is well again. I did some experimenting and found that 3.6 Dev works through the 5/31 release but everything I tried from this months releases give the logging fail. Logging parameters are set the same on both vehicles.

Cheers RB

What are those logging parameters you have set, and what is your hardware configuration?

Hardware configuration is identical on both vehicles and both have been flying the release candidates for two or more years. Solid test platforms with no issues.
Bit mask 176125
P2/here gps

Just discovered that the quad sets a bad logging message at start up but clears before it blocks pre-arm checks so it is not evident unless connected to ground station. Rc7 does not


Backend 3
Disarmed 0

So if you don’t don’t have a companion computer with a logging receiver, that’s why it’s failing. Set the backend to 1.

1 Like

Thanks Matt, sorry it’s been so long getting back to you but work interferes with my fun. It turns out that log backend setting is not an issue, my TX1 on the affected vehicle has a dedicated power switch to avoid power surge when connecting 6 fairly large ESC’s and on or off made no difference. I finally solved the problem by updating Mission Planner, loading a clean version of rc8 on a new Pix2 and copied my parameters over, worked just fine. Not sure what the problem was but after re-loading everything back up on the original Pix2, it also works.

Thanks again,
Cheers RB