3.5-rc8 PreArm: Logging Failed

Even with LOG_BACKEND_TYPE=0, whatever I try it won’t allow me to arm…

I’ve reformatted the SD card with the same result, although it’s the same SD card I’ve used since the beginning of time.
I’m guessing it might have something to do with this commit that went into 3.5-rc8?

What is the LOG_BITMASK set for? I found that 131071 fails. Been meaning to open an issue on that. I set it to 131070, which isn’t listed but is the old solo value. It works.

LOG_BITMASK is 176126 - I haven’t touched it so presume it must be default. Worked perfectly up until I flashed rc8

I have every flight logged since I got my IRIS in 2014. Over 300 logs and it works just fine with 3.5.RC8.

LOG_BITMASK = 131070

Log_backend_type=0 mean none or no logging.


@Iseries Not sure what you’re trying to say - that it works for you so it should for everyone? I too have hundreds of flights before without this problem, which came immediately after flashing to rc8. LOG_BACKEND_TYPE was set to 3, I turned it to 0 to try and get round this problem. You would not expect it to produce a Logging Failed error with no logging, nor for logging to be a prearm requirement.

OK this was partially my fault - I didn’t realise you have to reboot for the LOG_BACKEND_TYPE to take effect, once I changed it to 1 or 0 I’m not getting prearm failure now. Problem is if you have it set to LOG_BACKEND_TYPE=3 (or 2) and it doesn’t detect a mavlink log receiver, it fails pre-arm. This doesn’t seem necessary IMHO, a warning in this scenario would be valid but I don’t think it should fail pre-arm.
131071 works for me, btw.