3.5.2 on PIXRACER shot up sky and crashed


Several days ago, my quadcopter (PIXRACER loaded latest stable 352) crashed.
I have been flying this copter for more than half year, but with 3.4.X firmware, it flied well.
days ago, I changed the RC and RC and receiver with S.BUS, the copter became trembling, so, I decided to use auto-tune to calibrate the PID.

I connected the copter onto missionplanner and was told there are new firmwares and I reinstalled the ‘latest stable’ 352.

I was so confident with the copter (because I already used it long time and now its latest stable firmware), I after I finished basic necessary setup the next day I took off directly in Atl-Hld Mode.

the copter trembling and ascending quickly onto the sky, I was so terrified that I switched off RC hoping to triggle RTL,
from tele I saw the copter changed to FAILFAFE mode but it kept ascending and soon dispeared .

later from tele-log, I knew it ascend to about 914 M !!! then started lost altitude to 415M and dropp and crashed. FORtunally it crashed into a reservoir

there days I think about it, the problem may because of big viberation…what I feel bad is why “this old but dangerous problem” still not solved…


Post your tlogs from mission planner, if you have them.

Also, you should program a switch on your transmitter to be a motor stop switch…
It has saved me several times… Better to kill the motors and have the thing drop from the sky, than to fly away.

-edited to say the correct behavior is to switch flight mode to stabilize when something like this happens, but I usually don’t think clearly at the time… I ‘freak out’ and just hit the motor kill switch.