3.5.1 only showing 4 motors

I just updated my octa to firmware 3.5.1 and thought I had everything ready to go but when I pressed the safety switch 4 of the ESC’s were still beeping away. Brought it inside and looked further and it shows only 4 motors in the motor test screen of MP. Tried wiping the Pixhawk to Plane and back to Octa and I still have the same issue. Only thing I could find that was weird was the FRAME_CLASS was set to 0 instead of 3. Was there something else that needed to be changed?

Also, I tried uploading Octa-Quad and Quad and both said they didn’t need uploaded as it was already on the board.



Correction, maybe the FRAME_CLASS was the issue. Seems to be sorted out after a restart of the Pixhawk. Wasn’t this parameter set automatically in the past depending on which frame type you clicked on the firmware screen?

It was automatic before 3.5.0.( I think )

Now it’s manual.

Also I got the wrong frame class when i updated today (i have quad X but for some reason octa was marked). Struggled a lot with the motor tests since only a,c, e, g worked and i expected a,b,c,d CW from front right. :slight_smile: Can somebody explain what EKF primary change 0 is?

Copter-3.4.6 and higher (including AC3.5.1) run multiple EKFs in parallel and it automatically switches two the one that reports itself as more healthy. Normally you shouldn’t worry about this although if you see rapid and constant switching that might indicate that neither EKF is happy. This is quite rare and normally it requires one of the dev team to investigate this if you see this (like Paul Riseborough).

wiki: http://ardupilot.org/copter/docs/common-apm-navigation-extended-kalman-filter-overview.html

Hi, tnx for fast answer, if i remember correct it occured during intital setup and accelerometer calibration. Maybe the rapid moves when pos quad right /left up down caused it to be unhappy. First i got EKF primary change 0 then EKF primary change 1. Havent seen these afterwards so not need for further actions.
Regards Espen