3.4-rc6 ERR codes

I.ve updated to 3.4-rc6 on my 450 quad. when doing a mission, it takes off OK and switch to Position Hold, still OK, when I switch to Auto after about 1 second it goes into RTL, which it peforms nicely.
Checking my log it shows a ERR23-0 and ERR23-1 taking place. I cannot find information on these Ecode errors, Can anybody help me. I,ve checked TX loss on signal,Battery,Fence, All look OK

Thank you in advance

I,ve done some more searching and found that it says Terrain data is missing in the log. I have a Lindar lite fitted facing down that gives me a good ALT reading. On checking the configuration I have TERRAIN_ENABLE set to 0, and had TERRAIN_FOLLOW set 1. Which I have changed to TERRAIN_FOLLOW to 0. On my mission I have ALT set to Terrain
Was this the cause of the ERR faults I was getting. I cannot test for a few days, but would like to get a full flight in when I do

I am having the same trouble with “Terrain data missing” when attempting Auto mode with all terrain parameters turned off.

I will be watching with interest for a solution.

In order for terrain data to work a GCS must be connected so that the flight controller can request terrain data for the area it is flying in. Once it is loaded it is cached on the memory card in the terrain folder.


But if I have Terrain Data use turned off in all parameters, why am I still being refused Auto with “Terrain data missing”?
In some cases I will not have a live internet connection from the GCS, especially when using cached maps.

And when would the flight controller request the terrain data?
Is there any documentation on the exact mechanics of the Terrain data?

Have you got the ALT in the mission set to Terrain? If so change it to relative, that should sort it out for you.

If you go to this link http://ardupilot.org/copter/docs/terrain-following.html you will see that using a LIDAR LITE you do not need the GCS or the terrain data. Just having the ALT set to Terrain and to cnfirm that the LITE sensor is working OK.


Thanks for the suggestion @OAPpilot but the Mission Planner settings were Relative height for the waypoint mission.
I have not used Terrain anywhere that I can find.

Yet I still get “Failsafe: Terrain data missing” errors when switching to Auto.

Ok, it looks like things are mostly sorted out on this thread.

The two issues, OAPpilot’s and Mike Boland’s are different. I think OAPpilot has sorted out his problems and we’ve found the cause of Mike’s issue (it’s related to a bug in the RTK GPS driver strangely) and the fix will go out with AC3.4.2.

Hi rmackay9
I did another test flight using my lidar-lite and the ALT in mission planner set to terrain. I still got Fairsafe Terrain data missing. then it did RTL. I’ve enclosed the log file Line 23503 shows the ERR

8.BIN (1.4 MB)

I got same “Terrain data missing” error on AC3.4.2 even with GCS connected through Mavlink Bluetooth and Internet available. In the status window “ter_load” is 336, “ter_pend” is 0 so it seems like it even doesn’t request missing terrain, just RTL from the altitude right after takeoff. I don’t know how to force it to upload terrain data. Relative altitude missions work fine. Also I have a sonar rangefinder installed with effective range of 6 meters.

Hi Arif,

Next time create a new thread as this is an old one. From the wiki:

One common problem reported by users is the vehicle immediately disarms when the user switches to AUTO mode to start a mission while the vehicle is on the ground. The cause is the altitude reported by the range finder (which can be checked from the MP’s Flight Data screen’s Status tab’s sonar_range field) is shorter than the RNGFND_MIN_CM parameter which means the range finder reports “unhealthy” when on the ground. The solution is to reduce the RNGFND_MIN_CM value (to perhaps “5”).

That is most probably your issue.

Thank you for the answer, but this is not my issue (which I’m actually aware of). In fact, my vehicle does take off, climbs to about the sonar-range altitude (~7 meters AGL - found that out by reviewing the logs) and only then failsafe’s with “Missing Terrain Data” error to RTL.

Ok, then create a new thread with a log so we can try to help you.

Ok,will do. Thank you!