Servers by jDrones

3.4.6 Hexa lost motors output 5 & 6 and crash


(lucamax) #1

Hi ,
I was testing a Pixhaw replacement and flew around 20 minutes .
I noticed that motor 3 (output 6) often had a difficult start .
Very difficult it could be an Esc issue since with the previous Pixhawk I flew for a couple of hours without any problem and never had that start up issue on motor 3.

After the compass calibration because a different GPS I made a small test flight .
Compass was good, no EKF errors , loiter and heading were fine.

I tried to start Autotune but no reactions , I receive a voice message on my Taranis since I use Frisky mavlink on it but could not understand the meaning apart “waiting for…”.
I aborted Autotune since it doesn not seems to start (since 3.4.6 is always like this )

After a while I return close to the take off zone and suddenly motor 3 lost speed and stopped and after some seconds also motor 6 did the same , trying to control the copter and keep it level I switch to Alt Hold and with some lucky I was able to stop on a branch tree without any damage.

I suspect it is a defect on the Pixhawk even if during Mission Planner Motor Test , motors behavior is perfect.

2017-04-07 16-04-37.bin.zip (1.2 MB)


(lucamax) #2

Update , I guess I was wrong.

Motor 3 (output 6) seems to be defective , I connect another Esc programmed as the one mounted on the copter and the motor during Mission Planner Motor test at 40% and up of throttle starts to stutter and tends to stop.

It might be that opposite motor , number 6 , slowed down to keep copter attitude since during motor test it was perfect also over 50% throttle, no cogging at all.


(Jagger) #3

All the stuttering prop problems I’ve ever had have been down to bullet connectors.Specifically the sprung cage type that are most often offered for RC work.If you’ve got all soldered connections disregard this message.I solder all my bullets with cages up solid now.


(lucamax) #4

Hi,
no bullet connectors , everything is soldered .

After I changed the motor the problem seems to persist .
I finally changed the Esc and solved the problem.

It would be interesting if someone could explain where in the Logs the mechanical failure on motor 3 appears , thanks.


(Jagger) #5

Looks like it was struggling all the waythrough and let go near the end.