3.3rc7 "Fly-away"

Dear all
I may need some help trying to investigate the problem that this morning almost destroy my X8.
I am running Pixhawk with Fw3.3 rc7, dual ublox neo-m8 on x8 coaxial.

I was testing pid in althold for few minutes and then I switch to loiter. After few second at about 3-4 meter AGL the copter roll suddenly
I immediately try to investigate for hdop and visible satelite numbers, but everything seems to be fine.
The only really strange reading that I found is the altitude that somehow rise to 7 meter and there stay even after crash… while Pixhawk still recording and alive.

Any help will be really appreciated! :smiley:

tlog file

dataflasfh log

I wouldn’t call that a fly away. A fly away is when the copter does exactly that. Flies away from you until it runs out of battery and usually you never see it again. This was a crash.

What size/type of quad is that? drawing 50 amps on 6s has to be quite a large quad.

What motors and ESC?

Are you certain the minimum throttle is set high enough so the motors never stop spinning in flight?

Looking at the log quick, it is incomplete. Shows 50% power till the end of the log and nothing more.

Was there a power failure?

How are you powering the pixhawk? Did it turn off or reset?

Desired roll and pitch vs actual roll and pitch show dead on till the end of the log.

My guess is it was a power failure and since the log ends before the end of the flight.

I’m not expert on log analysis but that’s my guess.

Thanks alot Jman841, really appreciated!

this a X8 copter running Hobbywings xrotor-40pro ESC and DYS 4114-400kv motor
The pixhawk is powered by a separate 3 amps UBEC @5V (max 5 amps).

I noticed that the log is not complete but looking at the board voltage is fixed at 5 volts till the end of the registered log.
When the copter crash, the pixhawk was alive and emitting beep, therefore if the case of a power failure I would have expected a voltage board below 5 v. Would you agree?

What do you mean “minimum throttle is set high enough” ? I’ve done the esc calibration and set THR_MID to adjusted value after hovering in Stabilize, is that what you mean?

thanks for your help! :smiley:

Min Throttle should be set so when the stick is above 0% any motor will never stop spinning asto not have ESC Sync issues. I had this issue with one of my quads.

Basically go to the setup page and where it says “motor test” see what % Of throttle is needed to ensure themotor spins up properly each time you push the button, then set that value for your minimum throttle, or a bit above it.

thanks I will set it up! :smiley:

Yesterday I also checked other logs and discovered a couple of occurence of the error “PM = slow loop lines was found”, So looking at the SDcard and I noticed that altough I bought the Pixhawk from 3DR, there was installed a NON “certified” sdcard.
Not a big deal but I was expected to have some “approved” hardware compatibility buyibg from 3DR

Anyhow, just to be sure I am going to swap to a Kingston class 10