3.2rc2 Unable to download logs from APM


I have been succesfully running 3.2rc2 on 2 pixhawks, downloading logs without issue. Decided to try 3.2 on an APM2.6, and no matter what I do it refuses to download the logs through USB.

Anything I am missing here? :blush:

no one? :astonished:



Hi Stefan,

I fully understand this is Release Candidate software, the only reason I am running it is to help the project and progress the version release. I was under the impression this is the place to post issues as they are found.

I can’t give you logs, so the only additional info I can provide is:
-Mission planner version 1.3.5 build 1.1.5260.33055.
-Windows 8 64bit.
-APM 2.6 with external mag.

Thanks for your help -

How do you try to download the logs? Can you describe your steps?

I plug in the usb, and under “terminal”, I immediately press “log download”. Since upgrading the 3.2rc2, all I see is scrolling text.

If i plug in my 3.1.5 APM, or 2 other pixhawks running 3.2rc2 there is no issue. I’ve tried to re-load 3.2rc2 as well on the APM in question.

I also cannot get into CLI as the same thing occurs. I press “connect” immediately after plugging/powering the APM, and all I see is scrolling text. Pressing ‘enter’, or clicking ‘show settings’ or ‘tests’ does nothing

The CLI was removed from the APM version of AC from 3.2 on to save space. Log download goes now via MAVLink. In the MP flight display page is a tab “Dataflash logs” below the attitude indicator.

See #11 at viewtopic.php?f=100&t=7872

thank you for that! Unfortunately still no luck… I am able to list the logs, but downloading any of the 7 available - either individually or choosing “download all logs”, it starts the download but eventually give me a “Timeout on Read -GetLog” (image attached).

should i change radio settings?

anyone have any idea? :frowning:

Hi rapph

I have had the same problem.
Finally I changed in 3DR Radio Settings Mavlink from Mavlink to Raw Data.
Now it worked without issue.



Thank you for tip! I actually found that disabling ECC on both sides did the trick for me.


I’ve tried the rawdata option and still I get the timeout error.

This is on all my APMs and Pixhawks - can’t download logs!!!

Please help, anyone?

EDIT: Thanks raphh, I tried your tip with the ecc disabling and it works fine now!