3.2.1 and APM2.6 not holding altitude

I’m using this on a cinetank quad and normally fly in stable mode with FPV. Never have a problem or reason to use RTL but thought I would give it a try today. What I found out is it doesn’t hold it’s altitude. So I switched to stable to gain control and then tried Alt Hold and had the same problem. It sinks and if you give it throttle it rises but then when you center the stick it sinks and requires more and more throttle to rise. Got to the point that it wouldn’t rise even with full throttle so I switched to stable.

I thought my Throttle Midpoint was set wrong and it was. My hover is at 50% on my controller and it was set to 600 so I changed it to 500, took another flight and saw no change.

I’m sure this is something simple but I’m at a loss on what parameter to look at. Otherwise it has no other problems.


Here is the tlog. Is the dataFlash needed too?

Would probably be more useful to be honest.

I believe this is it but for some reason they all downloaded with 1969 year. The flight was yesterday.

Any idea what could be causing this constant loss of altitude? I use to use alt-hold and loiter modes a lot when i was learning how to FPV but now I just fly in stable. The scary part is, once I realized the problem recently of it not holding the altitude, I tried a RTL and that failed also. It would just gradually descend. My throttle when hovering is exactly at 50% and I have the throttle mid point set to 500.

Im having a similar problem my alt hold is not stable, the copter drifts up or down slowly, It does seem to hold but in 2m of altitude. This is my first copter, and first use of APM2.6 and AC3.2.1.
THR_DZ 100
THR_MID 336 (mean of hover)

Randy solved it on the other forum. It was just a parameter that mistakingly had 0. I think it was throttle_accel.