3.1.3 firmware wont arm, no errors, CLI motors not spin

Please help.
I was using this same build-- ( apm 2.0 on a dji 330 frame motors and dji esc ) before and loved it.
Had a crash and it went into the closet.
Put on the new arm this week , plugged it in and updated to the 3.1.3
No way will it arm the APM2.0
It also fails to run the motors in the motor test on the CLI.
Originally, I was getting throttle failsafe error and HUD screen showing the error and double flashing red led, but turned off failsafes and error went away. ( just did that to get it arming OK first
Now I get nothing, I have checked and rechecked many many times and no idea what to look for.
Twice I have hit the arm button and it has armed. arm unarm, arm unarm, tried on off, on off seem to be fixed, although I dont think I did anything. turned it off and went to bed.
Next morning , wont arm.
Screwed around for another 4 or 5 hours redoing the same processes over and over again and suddenly, it armed. This time, I went in to some basic settings to set back to make it flyable, and guess what, I wont arm. I am probably 10 hrs in just sitting here trying to arm this thing.
There are no messages on the HUD
The LED does not double blink like it does on a pre test.- just the notmal singe blink and it does not change
Pre-check has been disabled to ensure that was not my issue.
I do not get any reaction form the motors when in CLI motor test, they do nothing.
It has armed a couple times throughout the process, but by the time I got the props on it again, it would not arm.
It looks like I am not the only one that has had this issue.
My wife is kicking my *ss for sitting here for hours on end, any help would be appreciate.
BTW it also seems that the " load previous firmware" that was in previous versions is gone? can not even revert to an older version ( or at least I dont know how)
Any help is appreciated.

I hope this is not such a stupid issue that no-one even responds.
But I can take it, bring it on!

Did you try erasing the eprom and load the defaults back in. Then run the wizard and start from scratch. What version did you have on before?

To see the advanced features, put it into advanced mode. Ie previous version downloading.

Also, put the arming checks back on, the. You should get useful messages why it won’t arm.

And you need to check HDOP is <2m, otherwise it won’t arm

More info here copter.ardupilot.com/wiki/prearm_safety_check/

Not site what my old version was, 2.7 or 2.9 but under 3 for sure

I think I have ereased, eprom, have tried many things, but will do that again, and check my HDOP as well.
My gut tells me that I have an issue with my windows machine because anytime that I use it for firmware related issues, I seem to end up with corruption issues. That appiies to the apm, my multiwii and a open pilot board I have.
Seems very coincidental , can anyone comment on that?

new firmware update today, everything seems to have started working

Great. It does sound strange though, as the flashin process also has a verify step. If the flashing was unsuccessful the process would fail.