3.0.1 Tri corkscrews on take off

I have a large homebuilt rcexplorer-style tricopter APM 3.0.1. The motor configuration is:
[ul]2 oclock, clockwise rotation[/ul]
[ul]10 oclock, counterclockwise[/ul]
[ul]6 oclock, counterclockwise [/ul]
this is the second option for tricopters on the connecting-your-rc-input-and-motors page. All Tx/Rx controls seem correct, held in my hand, all controls on the tricopter respond in an expected way (I have also built and flown CC3D, KK2, and APM 1)…except the yaw seems to go into exagerated movements which results in a positive feedforward loop. When I try to take off, the tricopter corkscrews.

Am I missing something? It does not seem to be simply a PID problem. Though I suppose it could be.

Before configuring this tricopter, I erased and reset the APM 3.0.1 to get rid of any APM 1 quad settings.

Anyone have this problem before?

It might be PIDs as you have flown a tri before I am sure you have canted that rear servo slightly to start with?

It sounds like you need to get it holding heading harder.

Same problem.
As soon as my tricopter leaves the ground, it goes into a flat spin (either direction). This is identical to the problem described in 2011 at diydrones.com/forum/topics/how-t … tri-copter. Since there is no servo on quads, this apparently does not happen with them.

  1. 3D Robotics Ardupilot, APM 2.6, Arducopter V3.0.1, FW V: 120, Win 7, 64 bit.

Mode: stable.

  1. The rudder servo control is reversed. I reversed it back in the Tx. The apm now arms when I pull the stick to the left and then it works normally. Disarms when I pull to the right. Reversing the rudder control in the Tx does not change gyro corrections that send the tricopter in the wrong direction. The rudder control was not reversed with the same tricopter setup when I had a KK2 board. The entire tricopter worked perfectly with a KK2.
  2. Rudder servo is powered by the rudder motor UBEC. Only the signal wire runs from the rudder ESC to output #4. Only the signal wire runs from the servo to output #7. Except for being reversed, the rudder servo works normally.

Attempts to fix:

  1. Ran every calibration and setup multiple times.
  2. Tried every possible combination of lower Rate Yaw P value and with lower (and higher) Stable Yaw P values. No improvement.
  3. Replaced rear prop four times with carefully balanced props. No improvement.
  4. Ran rear motor without prop. Perfectly balanced at all throttle levels. Replaced and balanced rear motor. No improvement. Tricopter still goes into a flat spin as soon as it leaves the ground.

I suspect this problem was corrected in 2011, but a subsequent update removed the fix. At the moment, I’m grounded. Bummer. :frowning:

You have to reverse the servo in the APM config via Mission Planner, not in the TX.

I’m running mission planner 1.2.86 and there is NO option to reverse the channels in radio calibration mode. the check boxes to reverse a channel simply do not exist, either in “monitor” or “calibration” mode

Please help me coz my tricopter is corkscrewing on take off too and I know it just because the rudder channel needs to be reversed in the APM 2.6 but I cant find a way to do it. reversing the channel on the TX makes no difference - it still corkscrews…


Try reversing RC4 in parameters

thank you - that helped.

i still get the problem wherein the tricopter will randomly spin 180 when in stable mode. i have read the troubleshooting guide, and it just says it happens because people dont read the manual. well thats not too helpful, and yeah i have read the manual.

i remember seeing something that said if u have a apm 2.5 that you have to remove the case and cut a trace to allow the use of the external compass.

i’ve got the apm 2.6 with the 3DR GPS uBlox LEA-6 with Compass. i have the advanced parameter (COMPASS_ORIENT) = Roll180.

Do I still need to crack the case open and cut the trace?

No I don’t think you do as its done for you in the 2.6 I believe. Sounds like you have to give the tail more authority.

Ok fair enough. And how would i do that? Any suggestions as to a ballpark figure i could put into mission planner parameters?

Flip it upside down on table. Are all prop tips hitting table square centered? Then adjust rear prop with servo to be off about 3 degrees to counter prop spin. :slight_smile:

I’m using the Pixhawk and having same problem. I reversed RC_7. So basically when you make a input “left stick” the servo should go right. It seems on lift off the rear seams to sit lower as if more power needs to go to the rear motor. Then it cork screws. I’m sure it’s just tuning settings. I’m new to 3D Robotics so naturally the learning curve is high. However it’s plane to see even with my minor problems this is a far superior system.