2nd GPS problem setting up

I am trying to use RTK on the 2nd GPS and am having no luck!

My setup is as follows:
Holybro Pixhawk4
Pixhawk4 GPS module
Emlid M+ RTK (2nd GPS)
Emlid RS (BASE)

FRAME is a BOAT using skidsteer control
I have a SONAR connected to Telem2 port using a TTL converter
Setup as:


I have made a 6pin connector cable connecting as follows
[Pixhawk] [EMLID]

Settings all setup in EMLID REACH interface as follows:
BASE - TCP mode - RTCM

ROVER - correction input UART/38400/RTCM
- position output UART/38400/NMEA

I have connected the BASE in the RTK INJECT settings and get data showing in MP.

I have setup the MP parameters as follows:

As far as I can tell there is nothing else which needs to be set for this to work.
I get no Corrections coming to the M+ in the EM LID REACH app
I get no HDOP2 values
I get only a single GPS value in the GREEN display window on MP.

I have tried using a different EMLID M+ unit - this doesnt change anything
I have also tried using different cables

I have reflashed the PIXHAWK and manually reset all the settings.

Nothing I try will work? Is the PIXHAWK faulty UART port???

Please set GPS_INJECT_TO to 127

Hi I have tried setting this to 127.
I have also changed the GPS_AUTO_SWITCH to 0,1,2 and 3.

Nothing will work.

I have also tried to set the EMLID to ERB output… and associated MP GPS_TYPE parameter.

Nothing will work

Do not change it, just set it to 127, and let it stay there.

Emlid needs to be set to ERB and the GPS2_TYPE needs to be set to ERB as well.
Does it have the correct baudrate?

Is missionplanner happy with the base station, if yes, do not change it.

I Have tried these settings - Still not getting any data for GPS2

So this started to work this afternoon. I could see the grey bars in the emlid reach software showing I was getting corrections.
I had HDOP and also 2nd GPS showing in MP.
even managed to get an RTK fix (eventually I had to turn off Galileo sbas and beidou)
BUT… I have just switched on the system again and now I have nothing showing again!

Is there anything that could be causing this?

Yes, patience. You need to bring a lot of patience when working with (emlid) RTK systems. They take > 5 minutes to get a RTK fix.

This happens to me as well when powering the plane reach with the battery along with the autopilot at the same time. Sometimes gps2 is not detected. I think it is perhaps due to the time taken by emlid reach to initialise while the autopilot has already booted. Will try boot delay option in cube autopilot.