#2 Motor Won't Spin

I’ve built a Parallax Elev-8 quad, using an APM2.6 controller with external GPS, compass. I’m using an APM poser module to supply power to GPS, telemetry, etc. and power from one ESC to supply power to the rest of the ESC, servo rails. I have a 915 mhz telemetry link between the aircraft and a laptop running Mission Planner - the telemetry link works.

My problem is I cannot get the motors to arm. After a lengthy troubleshooting stint, I discovered a bad solder connection on one of the ESC power wires going to the #3 motor (I found #2, #3 motors wouldn’t spin using the motor test function in Mission Planner). I fixed the problem with #3, but #2 still souldn’t spin despite checking the wiring. I can plug the #2 ESC control into the throttle channel of the receiver and I can command the motor to run, but when I reconnect the ESC wire back into the APM and reconnect all receiver channels, I still can’t get the motor to spin.

This morning, I discovered that if I push the throttle stick to the left the motors will spin - all except #2… I’m about ready to abandon the APM autopilot and replace it with a Pixhawk as it is newer, and I’m hoping I can get some support from 3DR if I have problems. But I fear that my motor problem might be due to something else… Does anyone have any suggestions?

Okay, I think I found the culprit. I decided to tear down the aircraft to see if I could find any other bad solder joints or connection problems and I discovered a wire had come loose from a connector - one of five wires going from the APM power module to the APM itself. The plug looks damaged and a second wire was loose as well.

Since I don’t have a spare and no tools to replace the plug, I’ve ordered a new APM power module from Amazon - hopefully, it will arrive in a day or so.

I had a breakthrough last night. I tried one more experiment: I plugged a spare ESC into the aircraft’s power distribution harness and connected it to the #2 motor. I replaced all but one BEC wires (I have extensions in order to cover the distance from the ESC’s to the top of the APM where the output rail is). And it worked! I was able to get all four motors to pass the Motor Test!

But I am still unable to arm the motors. Now I have to decide if I should swap out the ESC’s or probe a little further to determine of the onboard ESC is okay (maybe one of the BEC’s was bad, or a loose connection where the #2 BEC plugs into the extension?

Still more work to do, and then I have to solve the arming problem…

After a lot of troubleshooting, taking the copter apart several times, checking and rechecking wiring, the problem migrated to the #1 motor. I tried swapping booms/motors and the problem remained with the boom/motor plugged into the #1 output port. Then, after some tweaking, I’d get the #1 motor to spin, but #3 motor would refuse to run. All of this was while the flight mode was Stabilize.

I completely disassembled the aircraft and had the electrons spread out on the floor. I finally decided that it must be a software problem or a faulty APM.

So, I put the aircraft back together, made a couple of small modifications: shortened the leads to the APM power module and power distribution harness and added some more vibration dampening. I reflashed the APM firmware, went through the calibrations, including ESC’s everything seemed fine - all four motors spun after ESC calibration.

But after power cycling the aircraft, I was back to #1 motor refusing to spin at all. I switched to Alt Hold mode and no change. But when I switched to RTL, all four motors spun up, as the aircraft was trying to climb to the default altitude for RTL. Switching back to Alt Hold or Stabilize however caused the same behavior - #1 motor refused to spin.

Based on this, I’m convinced I have a faulty APM.

MY 2 cents:

  • I assume you have calibrated the ESCs? If not, make absolutely sure they all calibrated. I had this exact problem when I did an “all-at-once” calibration and one ESC did not calibrate.
  • I had a similar problem yesterday (one motor vibrating badly and not arming at times) and diagnosed it by connecting the bum motor and ESC directly to the receiver throttle channel. If the motor spins and follows the throttle properly, then it is something between the APM and the ESC. If the motor does not spin, then its the ESC, motor, or power wiring. In my case, it was a prop with the hole in the wrong place. :astonished:
  • don’t use the ESC BECs to power the APM, they are usually very noisy electrically and cause GPS and APM problems

Hope this helps. I am still debugging my SK450 deadcat quad, so far I found:

  • bad APM power - I used ESCs to power APM
  • loose GPS mount (caused bad compass and GPS readings)
  • APM needed better vibration mounting and shielding of barometer from prop wash
  • bad GPS
  • bad prop
  • low power output from my computer USB - that was a b8tch to find
  • poor battery connections

Good luck.

Hummm, sounds very familiar. I’m setting up a F350 with an APM 2.6 and am having the same problem. One motor will “studder” on arming, “sometimes”! I even replaced that motor and ESC, same thing. Did the all in one ESC calibration, did them all together with a lead from the throttle channel. Did them one at a time. Tried an ESC programming card. Finally last night, went through a couple of solder points that I didn’t like the looks of. Seemed to be working. Have not tried yet today. ESC’s can be tricky sometimes. Also a strange thing I noticed. If I armed as soon as the red/blue lights stop flashing (initializing), all 4 motors would start normally. If I waited any longer, only 3 motors arm, with the same one studdering, every time! When all 4 motors arm, the thing flys perfect, all the functions work. This is I’m sure, an APM clone. I will do more testing today, if it stops raining! :smiley:

I finally solved my problem. Suspecting a defective APM (a Chinese clone), I bought one from 3D Robotics. After installing the firmware, going through the configurations, etc. the motors armed on the first try and all four propellers spin!

I have taken it out for a couple of short hover tests in my driveway - despite the strong breezes it flew fine - very stable. I flew in Stabilize mode. I have the following modes set up: Stabilize, Loiter and RTL. I will try Loiter mode later this evening. So far, I’m happy with the results!