2.5.2 Board will not arm after upgrade to 3.1 from 3.01

2 different boards worked great. Cant get either to arm after 3.1
flashing red
steady blue
steady green
chattering yellow tx/rx

following actions taken;
eeprom erase
3.1 stable loaded
all calibrations confirmed complete
CLI tests baro,compass,gps,ins all responsive with cognizant response to movement

usb/915mhz telemetry good both ways
channel 3 thr 1008-1912 pwm
" 5 yaw 1084-1522-1947 pwm
futaba 72mhz xmtr/rcvr ppm mode NOT PPM SUM

tried disabling ARMING_CHECK
does not annunciate any failed checks in HUD window when enabled
tried usb boot before lipo connect
muliple esc tried which op normal other craft
both one at a time all at once calibration performed [ turnigy plush 30A]

ive tried all the above multiple times
tried reverting to earlier FW no luck

any insight would be appreciated

So it must be either failing an arming check (which shouldn’t happen if the ARMING_CHECK parameter has been set to zero) or something more basic isn’t working which makes it not want to arm. For example if the throttle wasn’t right at the bottom or the yaw wasn’t all the way to the right…or the flight mode wasn’t set to Stabilize or Acro…or if the copter was being armed while in Loiter and it didn’t have GPS.

Best to provide a tlog I think.