2.0.20 known issues?

I’m just a standard user and I installed APM Planner 2.0.20 today. I understand it’s still relatively new so I wanted to share a couple of things I’ve found that do not function correctly. I’ve read in this forum one or two were supposed to or are currently being addressed.

Initial Setup tab

  1. Compass live calibration does not appear to function. A continuous error message appears “Not enough data points to calibrate the compass”
  2. Declination Website link does not work
  3. Calibrate accelerometer does not function. There is a 40 sec timer countdown but nothing else. At the end of the count a FAILURE: Failed CMD: 241 prompt appears

Config/Tuning tab

  1. Standard Parameters and Advanced Parameters screens are blank. There is no way to change anything so it basically makes the entire program useless

I thank you guys so very much for making this available to Mac users!!! I had been using Arducopter but I smashed my PC tablet yesterday and don’t want to buy a new one so I tried converting my Pixhawk to use Qgroundcontrol. That was a frustrating mess and then I discovered you guys had published an APM for Mac so I immediately downloaded it.

My bird is basically dead in the water until the next update so please, please Help a Brotha Out (HBO)
as quickly as possible.

Have you tried installing 2.0.23-rc1 and see if your issues disappear?

Didn’t see it in the downloads list so I’ll look again.

Preciate it

3D Accelerometer still does not work. Says it will ask you to place autopilot on each edge but does’t. Timer counts down and then fails.

What firmware version of ArduPioit are you using. If it’s pre AC3.4 you need to check that option and restart APM Planner for it to take…

2 posts were split to a new topic: Having problems downloading Parameters

This is fixed in 2.0.24 and now detects the ArduPilot FW version for Copter