2.0.18 wont start on my old MacOS 10.6.8


I get an error message when trying to start latest 2.0.18 version of APM2. I take it it requires some newer system to run on, but unfortunately it’s impossible to update the system on this laptop any more due to its age.

Please, can you make it run on MaxOS10.6.8 again?

Attaching error message below


Process: apmplanner2 [442]
Path: /Applications/APM Planner 2.0.app/Contents/MacOS/apmplanner2
Identifier: com.diydrones.apmplanner2
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: launchd [161]

Date/Time: 2015-07-01 10:37:06.081 +0200
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 4677968 sec
Crashes Since Last Report: 55
Per-App Interval Since Last Report: 655016 sec
Per-App Crashes Since Last Report: 26
Anonymous UUID: E45307D6-FF4A-4443-AC4A-CADBBADF19C0

Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /usr/lib/libc++.1.dylib
Referenced from: /Applications/APM Planner 2.0.app/Contents/MacOS/…/Frameworks/QtOpenGL.framework/Versions/5/QtOpenGL
Reason: image not found

Binary Images:
0x7fff5fc00000 - 0x7fff5fc3bdef dyld 132.1 (???) <69130DA3-7CB3-54C8-ABC5-423DECDD2AF7> /usr/lib/dyld

Model: MacBook2,1, BootROM MB21.00A5.B07, 2 processors, Intel Core 2 Duo, 2.16 GHz, 2 GB, SMC 1.17f0
Graphics: Intel GMA 950, GMA 950, Built-In, spdisplays_integrated_vram
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x87), Atheros 5416:
Bluetooth: Version 2.4.5f3, 2 service, 12 devices, 1 incoming serial ports
Serial ATA Device: FUJITSU MHW2120BH, 111,79 GB
Parallel ATA Device: HL-DT-ST DVDRW GSA-S10N
USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8501, 0xfd400000 / 2
USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8205, 0x7d100000 / 2
USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8240, 0x5d200000 / 2
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x021b, 0x1d200000 / 3
USB Device: FT231X USB UART, 0x0403 (Future Technology Devices International Limited), 0x6015, 0x1d100000 / 2

Are you using 2.0.18-rc1 or 2.0.18-rc2? Which one works

Rc2. Seems like something happened between 17 and 18. I run 2.0.17-61 with no such problems.

Sent using Tapatalk

RFA :slight_smile: Well, haven’t tried rc1. Will try this evening

Sent using Tapatalk

Rc2 uses Qt5.4.2 not Qt5.2.1 libraries. Maybe the new version doesn’t work on 10.6 anymore. ?

Oh, yeah, in the MacOS thrown error message above there is something mentioned about Library not loaded… So there is no chance it will be coded backward compatible (trow away old mac)?

Sent using Tapatalk

You can easily build it from source and run it in any case. It’s not trash yet!

[emoji54] eh, sorry, I’m not a programmer… You mean I can compile it on the of Mac to make it work? Never mind, you guys have more important issues to deal with [emoji6]

Sent from my iPhone using Tapatalk